Fix *initd, *confd and *envd calls (#173884, #174266)
authorTorsten Veller <tove@gentoo.org>
Sat, 28 Apr 2007 17:29:44 +0000 (17:29 +0000)
committerTorsten Veller <tove@gentoo.org>
Sat, 28 Apr 2007 17:29:44 +0000 (17:29 +0000)
Package-Manager: portage-2.1.2.5

12 files changed:
sys-power/nut/ChangeLog
sys-power/nut/nut-2.0.0-r1.ebuild
sys-power/nut/nut-2.0.0.ebuild
sys-power/nut/nut-2.0.1_pre4.ebuild
sys-power/nut/nut-2.0.3-r1.ebuild
sys-power/nut/nut-2.0.3.ebuild
sys-power/nut/nut-2.0.4-r1.ebuild
sys-power/nut/nut-2.0.4.ebuild
sys-power/nut/nut-2.0.5-r1.ebuild
sys-power/nut/nut-2.0.5.ebuild
sys-power/powernowd/ChangeLog
sys-power/powernowd/powernowd-0.90.ebuild

index 30007efa06e87e7bf3b10f51a254283c2f894a5b..342ccd5c812ed1630b892bd6d2c0918a99dd82e6 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-power/nut
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.36 2007/04/25 05:38:46 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.37 2007/04/28 17:27:04 tove Exp $
+
+  28 Apr 2007; Torsten Veller <tove@gentoo.org> nut-2.0.0.ebuild,
+  nut-2.0.0-r1.ebuild, nut-2.0.1_pre4.ebuild, nut-2.0.3.ebuild,
+  nut-2.0.3-r1.ebuild, nut-2.0.4.ebuild, nut-2.0.4-r1.ebuild,
+  nut-2.0.5.ebuild, nut-2.0.5-r1.ebuild:
+  Fix *initd, *confd and *envd calls (#173884, #174266)
 
   25 Apr 2007; Daniel Black <dragonheart@gentoo.org> files/upsd.rc6:
   added reload to upsd init script. bug #175928
index 711c8fd3b718a070b17737e95a8072b18e29922a..f797745ceb7b62655488339fab62d9e1a6516b74 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.0-r1.ebuild,v 1.2 2006/10/03 22:13:21 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.0-r1.ebuild,v 1.3 2007/04/28 17:27:04 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -105,10 +105,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        keepdir /var/lib/nut
 
index a89e83f7332269cf3fa19af336cff68801fbc271..f3d04fa6b579891bba44c65fe7e712806781db5f 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.0.ebuild,v 1.1 2006/05/15 23:43:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.0.ebuild,v 1.2 2007/04/28 17:27:05 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -105,10 +105,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        keepdir /var/lib/nut
 
index c4afad918e24850925dff9d85c931fc25a6a0e1f..07856017218f524f9b64356519c5f1a12a440da7 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.1_pre4.ebuild,v 1.1 2006/05/15 23:43:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.1_pre4.ebuild,v 1.2 2007/04/28 17:27:04 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -111,10 +111,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        keepdir /var/lib/nut
 
index 57a39e0858490949b15a00cbc78ea043d78666c0..13f4d70f2f436aebc1ef41409672f51bb003428e 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.3-r1.ebuild,v 1.10 2006/07/22 04:48:06 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.3-r1.ebuild,v 1.11 2007/04/28 17:27:05 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -133,10 +133,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        # This sets up permissions for nut to access a UPS
        insinto /etc/udev/rules.d/
index c9fd44b803ee13f857d902789d9e136d09cc0cfc..9af30628c7386e2b0d43f7724245d718e935dd7a 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.3.ebuild,v 1.1 2006/05/18 06:05:29 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.3.ebuild,v 1.2 2007/04/28 17:27:04 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -122,10 +122,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        # This sets up permissions for nut to access a UPS
        insinto /etc/udev/rules.d/
index 64d9aaae63facaa831ee3a394e95eada6d980d00..8d778f2fd157dc93e0d316ba7c9e78018f289261 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.4-r1.ebuild,v 1.12 2007/03/18 20:24:58 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.4-r1.ebuild,v 1.13 2007/04/28 17:27:04 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -135,10 +135,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        # This sets up permissions for nut to access a UPS
        insinto /etc/udev/rules.d/
index b6d3a4fa36bfb4640f17b3a57383a051dc891f83..1daa1bdc563fd00476bdeb3a76563bfd00285854 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.4.ebuild,v 1.1 2006/07/30 04:09:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.4.ebuild,v 1.2 2007/04/28 17:27:04 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -133,10 +133,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        # This sets up permissions for nut to access a UPS
        insinto /etc/udev/rules.d/
index 9abbe454a554d1e2b238682d456d1d28ee461a19..19f0f95ddbafbbc989bba7c1d6e4685f50959d32 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.5-r1.ebuild,v 1.6 2007/04/22 13:48:52 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.5-r1.ebuild,v 1.7 2007/04/28 17:27:04 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -138,10 +138,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        # This sets up permissions for nut to access a UPS
        insinto /etc/udev/rules.d/
index 43a5e4b3459f72016d77c1c3b52b183b931c93e6..f120fbdf423222986d4e4c2dd7501cd0c89d28f5 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.5.ebuild,v 1.2 2007/02/25 11:09:39 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.5.ebuild,v 1.3 2007/04/28 17:27:04 tove Exp $
 
 inherit eutils fixheadtails
 
@@ -137,10 +137,9 @@ src_install() {
        dodoc docs/cables/*
 
 
-       exeinto /etc/init.d
-       newexe "${FILESDIR}/upsd.rc6" upsd
-       newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
-       newexe "${FILESDIR}/upsmon.rc6" upsmon
+       newinitd "${FILESDIR}/upsd.rc6" upsd
+       newinitd "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+       newinitd "${FILESDIR}/upsmon.rc6" upsmon
 
        # This sets up permissions for nut to access a UPS
        insinto /etc/udev/rules.d/
index f6b98b998c3eec1b57b487d304ca7cae899a1510..35ed44a6f66ddbb96e375b32448f134fd623a004 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for sys-power/powernowd
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powernowd/ChangeLog,v 1.5 2007/02/22 00:38:51 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powernowd/ChangeLog,v 1.6 2007/04/28 17:29:44 tove Exp $
+
+  28 Apr 2007; Torsten Veller <tove@gentoo.org> powernowd-0.90.ebuild:
+  Fix *initd, *confd and *envd calls (#173884, #174266)
 
   22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
   Redigest for Manifest2
index 226d2eb5a426203703ca9d60b2969df8064489f5..b5293aa595d84d9cf33777d104a842ffa3fe8a52 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powernowd/powernowd-0.90.ebuild,v 1.2 2005/06/26 06:13:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powernowd/powernowd-0.90.ebuild,v 1.3 2007/04/28 17:29:44 tove Exp $
 
 EV=hun6
 DESCRIPTION="Daemon to control the speed and voltage of CPUs"
@@ -17,7 +17,7 @@ S="${WORKDIR}/${P}${EV}"
 
 src_unpack() {
        unpack ${A}
-       cd ${S}
+       cd "${S}"
        sed -i "s:-O2:${CFLAGS}:" Makefile
 }
 
@@ -30,8 +30,6 @@ src_install() {
        doman debian/powernowd.1
        dodoc README
 
-       insinto /etc/conf.d
-       newins ${FILESDIR}/powernowd.confd powernowd
-       exeinto /etc/init.d
-       newexe ${FILESDIR}/powernowd.rc powernowd
+       newconfd "${FILESDIR}"/powernowd.confd powernowd
+       newinitd "${FILESDIR}"/powernowd.rc powernowd
 }