app-emulation/xen-tools: add missed sec patches to vn. 4.6.0-r3
authorIan Delaney <idella4@gentoo.org>
Thu, 3 Dec 2015 13:12:34 +0000 (21:12 +0800)
committerIan Delaney <idella4@gentoo.org>
Thu, 3 Dec 2015 13:13:40 +0000 (21:13 +0800)
Already added to xen-4.5.2-r1, fixes gentoo bug.
Fix apparent typo re sec. patches in ebuild of 4.6.0-r3 only

Gentoo bug: #567190

Package-Manager: portage-2.2.24

app-emulation/xen-tools/xen-tools-4.6.0-r3.ebuild

index 156be8a20754cb44001f3581c0432e50c1dc1813..d13b307f58cbf2008a8d2b415b5ff441242d15ce 100644 (file)
@@ -45,7 +45,9 @@ else
                ${OVMF_PATCHSET_URI} )
        ${UPSTREAM_PATCHSET_URI}
        ${SECURITY_PATCHSET_URI}
-       ${GENTOO_PATCHSET_URI}"
+       ${GENTOO_PATCHSET_URI}
+       https://dev.gentoo.org/~idella4/distfiles/xen-security-patches-0.tar.gz"
+
        S="${WORKDIR}/xen-${MY_PV}"
 fi
 
@@ -164,7 +166,7 @@ pkg_setup() {
 src_prepare() {
        # Upstream's patchset
        if [[ -n ${UPSTREAM_VER} ]]; then
-               einfo "Try to apply Xen Upstream patcheset"
+               einfo "Try to apply Xen Upstream patch set"
                EPATCH_SUFFIX="patch" \
                EPATCH_FORCE="yes" \
                EPATCH_OPTS="-p1" \
@@ -173,7 +175,7 @@ src_prepare() {
 
        # Security patchset
        if [[ -n ${SECURITY_VER} ]]; then
-               einfo "Try to apply Xen Security patcheset"
+               einfo "Try to apply Xen Security patch set"
                source "${WORKDIR}"/patches-security/${PV}.conf
                # apply main xen patches
                for i in ${XEN_SECURITY_MAIN}; do
@@ -215,7 +217,7 @@ src_prepare() {
 
        # Gentoo's patchset
        if [[ -n ${GENTOO_VER} && -n ${GENTOO_GPV} ]]; then
-               einfo "Try to apply Gentoo specific patcheset"
+               einfo "Try to apply Gentoo specific patch set"
                source "${FILESDIR}"/gentoo-patches.conf
                _gpv=_gpv_${PN/-/_}_${PV//./}_${GENTOO_GPV}
                for i in ${!_gpv}; do
@@ -227,7 +229,7 @@ src_prepare() {
 
        # Ovmf's patchset
        if [[ -n ${OVMF_VER} ]] && use ovmf; then
-               einfo "Try to apply Ovmf patcheset"
+               einfo "Try to apply Ovmf patch set"
                pushd "${WORKDIR}"/ovmf-*/ > /dev/null
                EPATCH_SUFFIX="patch" \
                EPATCH_FORCE="yes" \