dev-python/tooz: allow usage of renamed msgpack
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 9 Mar 2018 17:51:40 +0000 (11:51 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 9 Mar 2018 17:58:53 +0000 (11:58 -0600)
Package-Manager: Portage-2.3.19, Repoman-2.3.6
RepoMan-Options: --force

dev-python/tooz/Manifest
dev-python/tooz/tooz-1.58.0-r1.ebuild [moved from dev-python/tooz/tooz-1.48.2.ebuild with 85% similarity]
dev-python/tooz/tooz-1.58.0.ebuild [deleted file]
dev-python/tooz/tooz-1.60.0-r1.ebuild [moved from dev-python/tooz/tooz-1.60.0.ebuild with 88% similarity]

index a139543bf7e1122b7eac348d497600afe37dfbb3..71677dbd3d72bec57d8ee2d37b7938375781e7ab 100644 (file)
@@ -1,3 +1,2 @@
-DIST tooz-1.48.2.tar.gz 78227 BLAKE2B 22155e51f52db5139ddf3156731071f77abc25192b86a9f758e775b966eee745d46da3ce4fb425c002a7fb56dbce0a168416087e453a35e2083b95fe523b8ed6 SHA512 47d3212e082c509fc44ac8baff6e66c490f065652f7fb1ae7791efcfb228d7ef4c17450727e81140810b9912bc2ab5bc18cac5f72c010e705bda0b2ee1b47d9c
 DIST tooz-1.58.0.tar.gz 81688 BLAKE2B 06e282850c549261a312d5381ac9004d13c96a90b10b3f682f2edbe3df5a1b4516a2e618d40d4625242fc18408bb38de56d1c9a58a998b843dd5c98f3d89917c SHA512 44886aed3b37e2a9cb2896fa30e22c7101f19fa766c75a2d7c82c9bcd13b47804ba6d140fe65d2b7c7f3ce3e12bf2f19fa1e92a8e147103204a608aba28f5ccd
 DIST tooz-1.60.0.tar.gz 85364 BLAKE2B 7c1f8cca02830accd5c72d09333f027a02d79944402affc80bb645c11a5a6ecbf94dc8acb62a1d1e98773458763a289134fe8603291e32b25dac507c68571a7d SHA512 610b7d30ce68954a687237c02d5529e93c1babe79bcf16de3674ae3c1d395202738a01dea91f8ffcb184717d884f777300152f54e6f971a4a42fc8bd500ad982
similarity index 85%
rename from dev-python/tooz/tooz-1.48.2.ebuild
rename to dev-python/tooz/tooz-1.58.0-r1.ebuild
index 70e4801997bc72df76a41c129114aefdc778b9c9..f1c631a6d9ca980e978d6554640e17cba878ce8e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -31,4 +31,10 @@ RDEPEND="${CDEPEND}
        !~dev-python/futurist-0.15.0[${PYTHON_USEDEP}]
        >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
        >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
-       "
+"
+
+python_prepare_all() {
+       # allow useage of renamed msgpack
+       sed -i '/^msgpack/d' requirements.txt || die
+       distutils-r1_python_prepare_all
+}
diff --git a/dev-python/tooz/tooz-1.58.0.ebuild b/dev-python/tooz/tooz-1.58.0.ebuild
deleted file mode 100644 (file)
index 70e4801..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library centralizing the most common distributed primitives"
-HOMEPAGE="http://docs.openstack.org/developer/tooz/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}"
-RDEPEND="${CDEPEND}
-       >=dev-python/stevedore-1.17.1[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-       virtual/python-enum34[${PYTHON_USEDEP}]
-       >=dev-python/voluptuous-0.8.9[${PYTHON_USEDEP}]
-       >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
-       >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
-       >=dev-python/tenacity-3.2.1[${PYTHON_USEDEP}]
-       virtual/python-futures[${PYTHON_USEDEP}]
-       >=dev-python/futurist-0.11.0[${PYTHON_USEDEP}]
-       !~dev-python/futurist-0.15.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
-       >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
-       "
similarity index 88%
rename from dev-python/tooz/tooz-1.60.0.ebuild
rename to dev-python/tooz/tooz-1.60.0-r1.ebuild
index 63b851ef4d9d3073c8e6d8557b6f8d2bf389b563..1d97d2da6418b97345c3c59f3970626970428b62 100644 (file)
@@ -31,3 +31,9 @@ RDEPEND="${CDEPEND}
        !~dev-python/futurist-0.15.0[${PYTHON_USEDEP}]
        >=dev-python/oslo-utils-3.18.0[${PYTHON_USEDEP}]
        >=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       # allow useage of renamed msgpack
+       sed -i '/^msgpack/d' requirements.txt || die
+       distutils-r1_python_prepare_all
+}