dev-perl/Class-Factory-Util: EAPI6 + Tests
authorKent Fredric <kentnl@gentoo.org>
Wed, 18 Oct 2017 21:15:38 +0000 (10:15 +1300)
committerKent Fredric <kentnl@gentoo.org>
Wed, 18 Oct 2017 21:39:06 +0000 (10:39 +1300)
- EAPI6
- Enable tests
- Cleanup author tests

Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/Class-Factory-Util/Class-Factory-Util-1.700.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Class-Factory-Util/Class-Factory-Util-1.700.0-r2.ebuild b/dev-perl/Class-Factory-Util/Class-Factory-Util-1.700.0-r2.ebuild
new file mode 100644 (file)
index 0000000..4b2ae30
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.7
+inherit perl-module
+
+DESCRIPTION="Provide utility methods for factory classes"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       >=dev-perl/Module-Build-0.28"
+
+src_test() {
+       perl_rm_files t/pod{,-coverage}.t
+       perl-module_src_test
+}