net-misc/youtube-dl: Update live ebuild
authorJeroen Roovers <jer@gentoo.org>
Wed, 25 Dec 2019 11:46:10 +0000 (12:46 +0100)
committerJeroen Roovers <jer@gentoo.org>
Wed, 25 Dec 2019 11:47:17 +0000 (12:47 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Bug: https://bugs.gentoo.org/703168
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/youtube-dl/youtube-dl-99999999.ebuild

index f30b1cfa0a046df0500c32bcef56d7976373e2a2..6e01390011675c74364054342a633053a11362c8 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="7"
-PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
+EAPI=7
+PYTHON_COMPAT=(python{2_7,3_{5,6,7,8}})
 inherit bash-completion-r1 distutils-r1 git-r3 readme.gentoo-r1
 
 DESCRIPTION="Download videos from YouTube.com (and more sites...)"
@@ -11,18 +11,22 @@ EGIT_REPO_URI="${HOMEPAGE}"
 LICENSE="public-domain"
 
 KEYWORDS=""
-RESTRICT="test"
 SLOT="0"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
+IUSE="test"
 RDEPEND="
-       ${DEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
        || (
                dev-python/pycryptodome[${PYTHON_USEDEP}]
                dev-python/pycrypto[${PYTHON_USEDEP}]
        )
 "
+DEPEND="
+       ${RDEPEND}
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/flake8[${PYTHON_USEDEP}]
+       )
+"
 
 src_compile() {
        distutils-r1_src_compile
@@ -30,6 +34,10 @@ src_compile() {
        emake ${PN}.{bash-completion,fish,zsh}
 }
 
+python_test() {
+       emake offlinetest
+}
+
 python_install_all() {
        dodoc README.md