x11-plugins/wmacpimon: bump EAPI and drop eutils
authorAaron Bauman <bman@gentoo.org>
Mon, 28 May 2018 23:46:21 +0000 (19:46 -0400)
committerAaron Bauman <bman@gentoo.org>
Tue, 29 May 2018 13:17:50 +0000 (09:17 -0400)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

x11-plugins/wmacpimon/files/Makefile.patch
x11-plugins/wmacpimon/files/wmacpimon.c.patch
x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild

index aab28fc89392263a3e8dd0e95e7c4efa1ff1b791..73646d10fa938489998c0f0bd90d253bc660c367 100644 (file)
@@ -1,5 +1,5 @@
---- Makefile   2010-09-06 11:33:16.000000000 +0200
-+++ Makefile.new       2010-09-06 11:36:28.000000000 +0200
+--- a/Makefile 2010-09-06 11:33:16.000000000 +0200
++++ b/Makefile 2010-09-06 11:36:28.000000000 +0200
 @@ -1,8 +1,5 @@
 -OPT   = -O3 -DACPI
 -
index 001c1d8c96bea1b837def8e37044b1899214f079..adc03ce3fd0ceeed6555acf08b393f1c5152c1a2 100644 (file)
@@ -1,5 +1,5 @@
---- wmacpimon.c        2004-07-08 14:16:22.184359328 +0200
-+++ wmacpimon.c        2004-07-08 14:15:59.677780848 +0200
+--- a/wmacpimon.c      2004-07-08 14:16:22.184359328 +0200
++++ b/wmacpimon.c      2004-07-08 14:15:59.677780848 +0200
 @@ -314,7 +314,7 @@
      acpinfo = calloc(1, sizeof(ACPInfo));
      dockapp->blink = OFF;
index d902e3de4a330545e39011bbb3920dfe81b319ab..ffc03d2648bb465de99cb50670e616768f60a0ec 100644 (file)
@@ -1,8 +1,7 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=2
-inherit eutils
+EAPI=6
 
 DESCRIPTION="DockApp monitors the temperature and Speedstep features in ACPI-based systems"
 HOMEPAGE="http://www.vrlteam.org/wmacpimon/"
@@ -19,18 +18,18 @@ RDEPEND="x11-libs/libX11
 DEPEND="${RDEPEND}
        x11-base/xorg-proto"
 
-src_prepare() {
+PATCHES=(
        # patch wmacpimon.c file to set default path for
        # wmacpimon.prc to /var/tmp/
-       epatch "${FILESDIR}"/wmacpimon.c.patch
+       "${FILESDIR}/wmacpimon.c.patch"
 
        # fix LDFLAGS ordering. See bug #248618.
        # fix LDFLAGS ordering again and other stuff. See bug #336091.
-       epatch "${FILESDIR}"/Makefile.patch
-}
+       "${FILESDIR}/Makefile.patch"
+)
 
 src_install() {
-       dobin wmacpimond wmacpimon || die "dobin failed."
+       dobin wmacpimond wmacpimon
        dodoc AUTHORS ChangeLog README
        newinitd "${FILESDIR}"/wmacpimon.initscript wmacpimon
 }