x11-misc/read-edid: Set CFLAGS=-fcommon
authorJeroen Roovers <jer@gentoo.org>
Wed, 29 Jan 2020 10:50:26 +0000 (11:50 +0100)
committerJeroen Roovers <jer@gentoo.org>
Wed, 29 Jan 2020 11:32:05 +0000 (12:32 +0100)
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Closes: https://bugs.gentoo.org/show_bug.cgi?id=706878
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/read-edid/read-edid-3.0.2.ebuild

index f55ccb264aa2d0988fca1fb41604e72211e8671c..cef6d33015a8203d4f3365e4f98e9f46fb724dbd 100644 (file)
@@ -1,9 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-
-inherit cmake-utils
+inherit cmake-utils flag-o-matic
 
 DESCRIPTION="Program that can get information from a PnP monitor"
 HOMEPAGE="http://www.polypux.org/projects/read-edid/"
@@ -21,3 +20,8 @@ src_prepare() {
                CMakeLists.txt || die
        cmake-utils_src_prepare
 }
+
+src_configure() {
+       append-cflags -fcommon
+       cmake-utils_src_configure
+}