dev-libs/intel-neo: bump to 20.16.16582
authorMarek Szuba <marecki@gentoo.org>
Sun, 26 Apr 2020 21:19:57 +0000 (22:19 +0100)
committerMarek Szuba <marecki@gentoo.org>
Sun, 26 Apr 2020 21:24:53 +0000 (22:24 +0100)
The first version in the tree supporting oneAPI Level Zero in
addition to OpenCL. Moreover, we now use centrally installed Khronos
OpenCL headers instead of bundled ones.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-libs/intel-neo/Manifest
dev-libs/intel-neo/intel-neo-20.16.16582.ebuild [new file with mode: 0644]
dev-libs/intel-neo/metadata.xml

index da3fb1383987d953250bc852673bb1c936649537..d9bbf0a28f9b6042f15b3eb80c6b2ef501df055c 100644 (file)
@@ -1,2 +1,3 @@
 DIST intel-neo-20.03.15346.tar.gz 2671869 BLAKE2B cf1e242563a377d533b1e5adc89257e3fdd879a0f275f069e9c1c3c8436e269a1ec57e951394d2a487148bfc5393fed0ce1f3feb6954c7ece9de59cccffd628c SHA512 4d2cc8fdcba714832306e6353e8688e12c44eb0f848aad981951ee092274ba8ae032db462b49e874b7ac72e1b8b2b9ba71a84b6715ca241c06a1c70e753e5ed3
 DIST intel-neo-20.10.16087.tar.gz 2942516 BLAKE2B ed77e5dfe950794e9e34cc6a0d8c053292b5673b9fa244ef7b861da93bb6aa58161ad890719013c838b0bbd80f3c22aaafc60dcb72a1e1e565cab51e5467c810 SHA512 8a728a3cffb5960dba8e8ecc160a6f0dd9c2cbadead3db3af2df71af492fdb346628a20c55112e64debb32eb25cf549e42dc78a606ef4bb8f746913781dbb446
+DIST intel-neo-20.16.16582.tar.gz 3042531 BLAKE2B adfc0aee2a315e67ccb3e4fe39ab09b618930607d3de931d1367881642d8e542385589299f593d3ab1cd6e16de7a8fce7b55fa1b4259097e15da7e55034d344b SHA512 700bee3ccf72c2bc89f5c8a75591de9dafbfe0a6480e3216258842c6b68ce1b527569d5fe1327a0a80cfbf79dca1d956820f060b602feefa83fc9b47cb46d7d0
diff --git a/dev-libs/intel-neo/intel-neo-20.16.16582.ebuild b/dev-libs/intel-neo/intel-neo-20.16.16582.ebuild
new file mode 100644 (file)
index 0000000..4cad604
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="compute-runtime"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for L0 and OpenCL, for Broadwell and beyond"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="l0 vaapi"
+
+BDEPEND="virtual/pkgconfig"
+COMMON=">=virtual/opencl-3
+       >=dev-util/intel-graphics-compiler-1.0.3826
+       >=media-libs/gmmlib-20.1.1
+       l0? ( >=dev-libs/level-zero-0.91.10 )
+       vaapi? (
+               x11-libs/libdrm[video_cards_intel]
+               x11-libs/libva
+       )"
+DEPEND="${COMMON}
+       dev-util/opencl-headers
+       media-libs/mesa"        # for Khronos OpenGL headers
+RDEPEND="${COMMON}"
+
+DOCS=(
+       README.md
+       FAQ.md
+)
+
+S="${WORKDIR}"/${MY_P}
+
+src_configure() {
+       local mycmakeargs=(
+               -DKHRONOS_HEADERS_DIR="${EPREFIX}/usr/include"
+               # CMake only sets this automatically for bundled OpenCL headers
+               -DNEO_EXTRA_DEFINES="CL_TARGET_OPENCL_VERSION=220"
+               -DKHRONOS_GL_HEADERS_DIR="${EPREFIX}/usr/include"
+               -DBUILD_WITH_L0=$(usex l0)
+               -DDISABLE_LIBVA=$(usex vaapi "no" "yes")
+               # If enabled, tests are automatically run during the compile phase
+               # - and we cannot run them because they require permissions to access
+               # the hardware.
+               -DSKIP_UNIT_TESTS=ON
+       )
+       cmake_src_configure
+}
index d7b990043c172b77255257156afc0f9e3c6b9184..0cb86b121696cc79f1b9ff9dbcbd7be4a5683c65 100644 (file)
@@ -5,11 +5,17 @@
                <email>marecki@gentoo.org</email>
                <name>Marek Szuba</name>
        </maintainer>
-       <longdescription>The Intel Graphics Compute Runtime for OpenCL, informally
-               known as NEO, is an open source project to converge Intel's development
-               efforts on OpenCL compute stacks supporting Gen8 graphics devices
-               (Broadwell architecture) and newer.</longdescription>
+       <longdescription>The Intel Graphics Compute Runtime for for oneAPI Level Zero and
+               OpenCL Driver, informally known as NEO, is an open source project providing
+               compute API support (Level Zero, OpenCL) for Intel graphics hardware
+               architectures (HD Graphics, Xe).
+               For OpenCL, NEO supports Intel Core processors with Gen8 graphics devices
+               (Broadwell architecture) and newer, as well as Intel Atom processors with Gen9
+               graphics devices (Apollo Lake, Gemini Lake).
+               Level Zero support is more limited and as of April 2020 still in early stages,
+               please consult upstream release notices for details.</longdescription>
        <use>
+               <flag name="l0">Install the oneAPI Level Zero driver alongside the OpenCL one</flag>
                <flag name="vaapi">Support the sharing of surfaces with Video Acceleration API
                        (OpenCL Extension #36)</flag>
        </use>