sci-chemistry/gelemental: use xdg-utils eclass
authorMatthias Maier <tamiko@gentoo.org>
Fri, 1 May 2020 17:46:01 +0000 (12:46 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Fri, 1 May 2020 17:48:50 +0000 (12:48 -0500)
Closes: https://bugs.gentoo.org/720308
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
sci-chemistry/gelemental/gelemental-2.0.0-r1.ebuild [moved from sci-chemistry/gelemental/gelemental-2.0.0.ebuild with 77% similarity]

similarity index 77%
rename from sci-chemistry/gelemental/gelemental-2.0.0.ebuild
rename to sci-chemistry/gelemental/gelemental-2.0.0-r1.ebuild
index 96fbcf235cb4a276039276b8333140e904ad0f6b..4affe1b9171e88f440cf9dee726266a6e7516c08 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit autotools fdo-mime flag-o-matic gnome2-utils eutils
+inherit autotools eutils flag-o-matic xdg-utils
 
 DESCRIPTION="Periodic table viewer with detailed information on the chemical elements"
 HOMEPAGE="https://github.com/ginggs/gelemental/"
@@ -36,11 +36,13 @@ src_configure() {
 }
 
 pkg_postinst() {
-       gnome2_icon_cache_update
-       fdo-mime_desktop_database_update
+       xdg_icon_cache_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
 }
 
 pkg_postrm() {
-       gnome2_icon_cache_update
-       fdo-mime_desktop_database_update
+       xdg_icon_cache_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
 }