sys-devel/parity: upstream changed arch names; drop _ in USE
authorMichael Haubenwallner <haubi@gentoo.org>
Mon, 9 Mar 2020 14:36:08 +0000 (15:36 +0100)
committerMichael Haubenwallner <haubi@gentoo.org>
Mon, 9 Mar 2020 14:55:26 +0000 (15:55 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
sys-devel/parity/metadata.xml
sys-devel/parity/parity-9999.ebuild

index 40c8b82ed8b68e7d55f5539f3371d2ea78d8a64a..606de9ef652a8687501a889f10cba7a187ca72a1 100644 (file)
@@ -19,7 +19,7 @@
                <flag name="vc14_0">Enable support for Visual Studio 2015</flag>
                <flag name="vc15">Enable support for Visual Studio 2017</flag>
                <flag name="vc16">Enable support for Visual Studio 2019</flag>
-               <flag name="vc_x64">Enable support for 64bit Visual Studio compilers</flag>
-               <flag name="vc_x86">Enable support for 32bit Visual Studio compilers</flag>
+               <flag name="vcx64">Enable support for 64bit Visual Studio compilers</flag>
+               <flag name="vcx86">Enable support for 32bit Visual Studio compilers</flag>
        </use>
 </pkgmetadata>
index f1ec325bab1f4b3d7675e1b1856f2df0eaabf41e..d6b23a8c4e0390645aa63639595cb1a8ec40a2fb 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -9,12 +9,12 @@ if [[ ${PV} == 9999 ]]; then
        DEPEND="dev-util/confix"
 else
        SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-       KEYWORDS=""
+       KEYWORDS="~x64-cygwin"
 fi
 DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
 HOMEPAGE="https://github.com/haubi/parity"
 
-parity-vcarchs() { echo x64 x86 ; }
+parity-vcarchs() { echo x64=x86_64 x86=i686 ; }
 parity-vcvers-legacy() { echo 7_0 7_1 8_0 9_0 ; }
 parity-vcvers-current() { echo 10_0 11_0 12_0 14_0 15 16 ; }
 parity-vcvers() {
@@ -25,7 +25,7 @@ parity-vcvers() {
 LICENSE="LGPL-3"
 SLOT="0"
 IUSE="$(
-       for a in $(parity-vcarchs); do echo "+vc_${a}"; done
+       for a in $(parity-vcarchs); do echo "+vc${a%=*}"; done
        for v in $(parity-vcvers-legacy); do echo "vc${v}"; done
        for v in $(parity-vcvers-current); do echo "+vc${v}"; done
 )"
@@ -41,8 +41,8 @@ fi
 parity-enabled-vcarchs() {
        local enabled= a
        for a in $(parity-vcarchs) ; do
-               if use vc_${a} ; then
-                       enabled+=",${a}"
+               if use vc${a%=*} ; then
+                       enabled+=",${a#*=}"
                fi
        done
        echo ${enabled#,}