dev-python/pytest-aiohttp: version bump to 0.3.0
authorTim Harder <radhermit@gentoo.org>
Fri, 1 Jun 2018 08:15:59 +0000 (04:15 -0400)
committerTim Harder <radhermit@gentoo.org>
Mon, 4 Jun 2018 23:33:27 +0000 (19:33 -0400)
dev-python/pytest-aiohttp/Manifest
dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild [new file with mode: 0644]

index eedfe1900e8ca209a1ad6cc304502c5359200997..cb79e61ef80659de26601f259c560730565002de 100644 (file)
@@ -1 +1,2 @@
 DIST pytest-aiohttp-0.1.3.tar.gz 6192 BLAKE2B 23f4eebdefe757328fc8621e29810835fee8e8c3e8cedf45134716cff77208bcd7aa82f537ada5d567b143d342b1a9fa14a5ed1e5208548e55353de1748b270c SHA512 2271f7730b91812a619e04522c13b7e2ff76353179a4588226d0b943b67f7397b966c1d3c24016861cc3eda3a541b3f0d3b2858a6ca3586f7707e10581c34e4c
+DIST pytest-aiohttp-0.3.0.tar.gz 6884 BLAKE2B 02b50fcd14192d23a4b257c2b7cb235966eff52b1c0ac87a4c61a20bc0babdb22eb999938c63e267a797d52ce57c9fb471232db3d0bc6566168a2d73f6404cd4 SHA512 4164166465dc40ff78a86304d1bcd4db9fb3f7dad3188f8ebe2ff151ed51eb0bf9c1b7a608d94cfe3339ee3b6efd4d5abbaa0691388460d5ac95635afa14984c
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..4c90767
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       dev-python/pytest[${PYTHON_USEDEP}]
+       >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"