dev-perl/CSS-Squish: -r bump for EAPI7
authorKent Fredric <kentnl@gentoo.org>
Fri, 8 May 2020 01:42:15 +0000 (13:42 +1200)
committerKent Fredric <kentnl@gentoo.org>
Fri, 8 May 2020 01:42:15 +0000 (13:42 +1200)
- EAPI7
- Parallel tests
- Strip useless tests
- Add license note re bug https://bugs.gentoo.org/718946

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/CSS-Squish/CSS-Squish-0.100.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/CSS-Squish/CSS-Squish-0.100.0-r2.ebuild b/dev-perl/CSS-Squish/CSS-Squish-0.100.0-r2.ebuild
new file mode 100644 (file)
index 0000000..969b959
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=TSIBLEY
+DIST_VERSION=0.10
+inherit perl-module
+
+DESCRIPTION="Compact many CSS files into one big file"
+# License note: "perl 5.8.3 or later" bug https://bugs.gentoo.org/718946
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       virtual/perl-File-Spec
+       virtual/perl-Scalar-List-Utils
+       dev-perl/URI
+"
+BDEPEND="
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               ${RDEPEND}
+               dev-perl/Test-LongString
+       )
+"
+PERL_RM_FILES=(
+       "t/99-pod-coverage.t"
+       "t/99-pod.t"
+)