www-servers/varnish: version bump to 4.1.0
authorAnthony G. Basile <blueness@gentoo.org>
Mon, 5 Oct 2015 08:17:35 +0000 (04:17 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Mon, 5 Oct 2015 08:21:38 +0000 (04:21 -0400)
Package-Manager: portage-2.2.20.1

www-servers/varnish/Manifest
www-servers/varnish/varnish-4.1.0.ebuild [new file with mode: 0644]

index e8df026f0b3f2f8561dbd77925017a1308595229..f05044f0488fb6d26d3a4a4c16efcb7ed8ced30a 100644 (file)
@@ -5,3 +5,4 @@ DIST varnish-4.0.0.tar.gz 2372630 SHA256 4bbf73656be11687cbb8c7d4a73157860816876
 DIST varnish-4.0.1.tar.gz 1877657 SHA256 49c3cebc89cb08fbc89d6680c1c8b42efc9313888172f3cdbdae7324b5c8f35b SHA512 e1ae846ff5b5e6ac0b694e8b197f9f7ec8c47677cbaaab6c0c490b6d5fa52f58f84fa3001bee8fe57451328cb809be0b5be55ddb41bd9c2444f23e0af582116b WHIRLPOOL 3013ae885a1eb6d44600b7c5513109a526cbed8f6bf687a81fa31111088713d68a9a059a67912966d7bed3b6404988c5fc785f02c91a63ea1f2a5037caf21e7b
 DIST varnish-4.0.2.tar.gz 1853668 SHA256 d9fb6a6eaf05bbb0c8eb5855556a4b092183b2c1a61281bfd73adf83a304555b SHA512 262bef5823f56c70fa9c7f24225b02b0218889c216143f63bb11db978ca7eddb174f605a5e48a4e774d88b20af5f5845bb2a6aef6fa3aaaf7cacd8c7c17cb82f WHIRLPOOL 35977069c6908a2fd731984585b447055730a288300de8709d83bec2df3677337535970c503b3b3d26635b0c747e7c387a423d93e776a755b8d8f0078c845696
 DIST varnish-4.0.3.tar.gz 1866760 SHA256 94b9a174097f47db2286acd2c35f235e49a2b7a9ddfdbd6eb7aa4da9ae8f8206 SHA512 db7bb141afd4617ac95573983dc30591b0eb9bc1af06df1094f2c1eeac539da936afb4a239d2f446d3c3a51b88a781b7f9f6d9a0b2028eaf0e7049ea2159d883 WHIRLPOOL 942456e19be427859283959dabe5522667519d36decbc598c8ee1e949767ea7435469393289d4373db6abac5275e50a95fc3799a837dc17740a490b4912bfe6f
+DIST varnish-4.1.0.tar.gz 1990932 SHA256 4a6ea08e30b62fbf25f884a65f0d8af42e9cc9d25bf70f45ae4417c4f1c99017 SHA512 b50aaa41247b912b40307423f99ae519ae5e19bea3546b049f148661727887f06b3d27712e685c219ae18cb6d53d89b415ddbd10bada7cfac00b2fd995995f5c WHIRLPOOL ae462819521b2ad5df29e82a1966190b849eba2c0d9d146cf97c8a0dba325653c24a6c67ed8a154c1cb1cba6a1a25c78bfda6d83deff72ad7756a57725521d92
diff --git a/www-servers/varnish/varnish-4.1.0.ebuild b/www-servers/varnish/varnish-4.1.0.ebuild
new file mode 100644 (file)
index 0000000..9bf65e5
--- /dev/null
@@ -0,0 +1,105 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit user autotools-utils eutils systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="http://www.varnish-cache.org/"
+SRC_URI="http://repo.varnish-cache.org/source/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+       || ( dev-libs/libedit sys-libs/readline )
+       dev-libs/libpcre[jit?]
+       jemalloc? ( dev-libs/jemalloc )
+       sys-libs/ncurses"
+
+#varnish compiles stuff at run time
+RDEPEND="
+       ${PYTHON_DEPS}
+       ${CDEPEND}
+       sys-devel/gcc"
+
+DEPEND="
+       ${CDEPEND}
+       dev-python/docutils
+       virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+DOCS=( README doc/changes.rst )
+
+AUTOTOOLS_AUTORECONF="yes"
+
+pkg_setup() {
+       ebegin "Creating varnish user and group"
+       enewgroup varnish 40
+       enewuser varnish 40 -1 /var/lib/varnish varnish
+       eend $?
+}
+
+src_prepare() {
+       # Remove bundled libjemalloc. We also fix
+       # automagic dep in our patches, bug #461638
+       rm -rf lib/libjemalloc
+
+       autotools-utils_src_prepare
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable static-libs static)
+               $(use_enable jit pcre-jit )
+               $(use_with jemalloc)
+       )
+       autotools-utils_src_configure
+}
+
+src_install() {
+       autotools-utils_src_install
+
+       python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+       newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+       newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+       newinitd "${FILESDIR}"/varnishncsa.initd-r1 varnishncsa
+       newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+       newinitd "${FILESDIR}"/varnishd.initd-r3 varnishd
+       newconfd "${FILESDIR}"/varnishd.confd-r3 varnishd
+
+       insinto /etc/logrotate.d/
+       newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+       diropts -m750
+
+       dodir /var/log/varnish/
+
+       systemd_dounit "${FILESDIR}/${PN}d.service"
+
+       insinto /etc/varnish/
+       doins lib/libvmod_std/vmod.vcc
+       doins etc/example.vcl
+
+       fowners root:varnish /etc/varnish/
+       fowners varnish:varnish /var/lib/varnish/
+       fperms 0750 /var/lib/varnish/ /etc/varnish/
+}
+
+pkg_postinst () {
+       elog "No demo-/sample-configfile is included in the distribution.  Please"
+       elog "read the man-page for more info.  A sample configuration proxying"
+       elog "localhost:8080 for localhost:80 is given in /etc/conf.d/varnishd."
+}