-DIST ilbc-rfc3951.tar.gz 330306 BLAKE2B cf8c56d9fc3dd2dc6a2dd241f3b0cddb7e7f6cea126056d2ab94aaf8add382f1bc1d9b03c9a91110197e0d82253ca8e824cf37bc1622af26fdf0939204736c35 SHA512 7828a9c5a193ebdfcb383d1edad0868afdee0f71d1a8a878c7d9ea2078fd63f57d31b34ae2cf4890d5abc28c8f5f4ee940c665a126f0512d1e79c4f76a72fbcf
+DIST ilbc-rfc3951-0.tar.gz 330306 BLAKE2B cf8c56d9fc3dd2dc6a2dd241f3b0cddb7e7f6cea126056d2ab94aaf8add382f1bc1d9b03c9a91110197e0d82253ca8e824cf37bc1622af26fdf0939204736c35 SHA512 7828a9c5a193ebdfcb383d1edad0868afdee0f71d1a8a878c7d9ea2078fd63f57d31b34ae2cf4890d5abc28c8f5f4ee940c665a126f0512d1e79c4f76a72fbcf
---- src/Makefile.am.orig 2006-07-11 01:18:20.000000000 +1000
-+++ src/Makefile.am 2006-07-11 01:21:20.000000000 +1000
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -10,6 +10,8 @@
doCPLC.c gainquant.c hpOutput.c iLBC_define.h lsf.c syntFilter.c \
doCPLC.h gainquant.h hpOutput.h iLBC_encode.c lsf.h syntFilter.h
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils autotools
+inherit autotools
DESCRIPTION="iLBC is a speech codec suitable for robust voice communication over IP"
HOMEPAGE="https://webrtc.org/license/ilbc-freeware/"
-SRC_URI="http://simon.morlat.free.fr/download/1.1.x/source/ilbc-rfc3951.tar.gz"
+SRC_URI="http://simon.morlat.free.fr/download/1.1.x/source/ilbc-rfc3951.tar.gz -> ${P}.tar.gz"
# relicensed under 3-clause BSD license, bug 390797
LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ppc ppc64 sparc x86"
-IUSE=""
S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${PN}-asneeded.patch )
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-asneeded.patch
+src_prepare() {
+ default
eautoreconf
}
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static
+}
+
src_install() {
- emake DESTDIR="${D}" install || die
+ default
+ find "${D}" -name '*.la' -delete || die
}