kde-misc/basket: Fix build against >=dev-libs/libgit2-0.99
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 1 Mar 2020 22:01:05 +0000 (23:01 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 1 Mar 2020 22:02:11 +0000 (23:02 +0100)
Thanks-to: Dan Goodliffe <gentoo@randomdan.homeip.net>
Closes: https://bugs.gentoo.org/710832
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-misc/basket/basket-2.49b.ebuild
kde-misc/basket/files/basket-2.49b-libgit2-0.99-compat.patch [new file with mode: 0644]

index 6a9fcbf3e6a7af4fbea5d02b9209ed202c0baaf8..bbcfe4d1009ef114e7b4f40091b088717eec32b0 100644 (file)
@@ -57,7 +57,10 @@ DEPEND="${RDEPEND}
        >=dev-qt/qtconcurrent-${QTMIN}:5
 "
 
-PATCHES=( "${FILESDIR}/${P}-xdg_mime_install_dir.patch" )
+PATCHES=(
+       "${FILESDIR}/${P}-xdg_mime_install_dir.patch"
+       "${FILESDIR}/${P}-libgit2-0.99-compat.patch" # bug #710832
+)
 
 src_prepare() {
        ecm_src_prepare
diff --git a/kde-misc/basket/files/basket-2.49b-libgit2-0.99-compat.patch b/kde-misc/basket/files/basket-2.49b-libgit2-0.99-compat.patch
new file mode 100644 (file)
index 0000000..94793a0
--- /dev/null
@@ -0,0 +1,32 @@
+From 094580f207b5ba9f44e9af00834f9c93f06fb440 Mon Sep 17 00:00:00 2001
+From: Dan Goodliffe <dan@randomdan.homeip.net>
+Date: Thu, 27 Feb 2020 18:04:21 +0000
+Subject: [PATCH] Use LIBGIT2_VER_MINOR for version test
+
+Addresses compatibility with libgit2-0.99
+---
+ src/application.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/application.cpp b/src/application.cpp
+index c52fb574..81fcd121 100644
+--- a/src/application.cpp
++++ b/src/application.cpp
+@@ -56,7 +56,7 @@ Application::Application(int &argc, char **argv)
+     #ifdef WITH_LIBGIT2
+-        #if LIBGIT2_SOVERSION >= 22
++        #if LIBGIT2_VER_MINOR >= 22
+             git_libgit2_init();
+         #else
+             git_threads_init();
+@@ -67,7 +67,7 @@ Application::Application(int &argc, char **argv)
+ Application::~Application()
+ {
+     #ifdef WITH_LIBGIT2
+-        #if LIBGIT2_SOVERSION >= 22
++        #if LIBGIT2_VER_MINOR >= 22
+             git_libgit2_shutdown();
+         #else
+             git_threads_shutdown();