sys-block/partimage: Drop 0.6.9 (r0)
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 15 May 2019 17:57:06 +0000 (19:57 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Jun 2019 21:18:37 +0000 (23:18 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-block/partimage/files/partimaged.init [deleted file]
sys-block/partimage/files/partimaged.pam [deleted file]
sys-block/partimage/partimage-0.6.9.ebuild [deleted file]

diff --git a/sys-block/partimage/files/partimaged.init b/sys-block/partimage/files/partimaged.init
deleted file mode 100644 (file)
index 72891f9..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License, v2 or later
-
-PARTIMAGED="/usr/sbin/partimaged"
-
-failed_startup() {
-       eerror "The PartImage daemon did not start up correctly."
-       eerror "Perhaps you compiled it with SSL support but forgot to run the ebuild config?"
-       return 1
-}
-
-depend() {
-       need net
-}
-
-start() {
-       ebegin "Starting partimaged"
-       start-stop-daemon --start --quiet --exec ${PARTIMAGED} \
-       -- ${PARTIMAGED_OPTS} --daemon > /dev/null 2>&1
-       eend $? || failed_startup
-}
-
-stop() {
-       ebegin "Stopping partimaged"
-       start-stop-daemon --stop --exec ${PARTIMAGED}
-       eend $?
-}
diff --git a/sys-block/partimage/files/partimaged.pam b/sys-block/partimage/files/partimaged.pam
deleted file mode 100644 (file)
index 6ffb16f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-# PAM config file for Partimaged
-
-auth required pam_unix.so
-auth required pam_warn.so
-auth required pam_listfile.so \
-       onerr=fail item=user sense=allow \
-       file=/etc/partimaged/partimagedusers
-
-account    include      system-auth
-session    include      system-auth
-
diff --git a/sys-block/partimage/partimage-0.6.9.ebuild b/sys-block/partimage/partimage-0.6.9.ebuild
deleted file mode 100644 (file)
index f0969dd..0000000
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils flag-o-matic pam user
-
-DESCRIPTION="Console-based application to efficiently save raw partition data to image file"
-HOMEPAGE="http://www.partimage.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
-IUSE="nls nologin pam ssl static"
-
-LIBS_DEPEND="app-arch/bzip2
-       >=dev-libs/newt-0.52
-       >=sys-libs/slang-2
-       sys-libs/zlib
-       ssl? ( dev-libs/openssl )"
-PAM_DEPEND="!static? ( pam? ( virtual/pam ) )"
-RDEPEND="${PAM_DEPEND}
-       !static? ( ${LIBS_DEPEND} )"
-DEPEND="${PAM_DEPEND}
-       ${LIBS_DEPEND}
-       nls? ( sys-devel/gettext )"
-
-pkg_setup() {
-       enewgroup partimag 91
-       enewuser partimag 91 -1 /var/lib/partimage partimag
-}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-zlib-1.2.5.2.patch #405323
-       epatch "${FILESDIR}"/${P}-minor-typo.patch #580290
-}
-
-src_configure() {
-       # XXX: Do we still need these?
-       filter-flags -fno-exceptions
-       use ppc && append-flags -fsigned-char
-
-       local myconf
-
-       use nologin && myconf="${myconf} --disable-login"
-
-       if use pam && ! use static; then
-               myconf="${myconf} --enable-pam"
-       fi
-
-       econf \
-               --docdir="${EPREFIX}"/usr/share/doc/${PF} \
-               --sysconfdir="${EPREFIX}"/etc \
-               $(use_enable nls) \
-               $(use_enable ssl) \
-               --disable-pam \
-               $(use_enable static all-static) \
-               --with-log-dir="${EPREFIX}"/var/log/partimage \
-               ${myconf}
-}
-
-src_install() {
-       default
-
-       keepdir /var/lib/partimage
-       keepdir /var/log/partimage
-
-       newinitd "${FILESDIR}"/partimaged.init.2 partimaged
-       newconfd "${FILESDIR}"/partimaged.conf partimaged
-
-       if use ssl; then
-               insinto /etc/partimaged
-               doins "${FILESDIR}"/servercert.cnf
-       fi
-
-       if use pam; then
-               newpamd "${FILESDIR}"/partimaged.pam.2 partimaged
-       fi
-}
-
-confdir=${EROOT}/etc/partimaged
-privkey=${confdir}/partimaged.key
-cnf=${confdir}/servercert.cnf
-csr=${confdir}/partimaged.csr
-cert=${confdir}/partimaged.cert
-
-pkg_config() {
-       if use ssl; then
-               ewarn "Please customize /etc/partimaged/servercert.cnf before you continue!"
-               ewarn "Press Ctrl-C to break now for it, or press enter to continue."
-               read
-               if [ ! -f ${privkey} ]; then
-                       einfo "Generating unencrypted private key: ${privkey}"
-                       openssl genrsa -out ${privkey} 1024 || die
-               else
-                       einfo "Private key already exists: ${privkey}"
-               fi
-               if [ ! -f ${csr} ]; then
-                       einfo "Generating certificate request: ${csr}"
-                       openssl req -new -x509 -outform PEM -out ${csr} -key ${privkey} -config ${cnf} || die
-               else
-                       einfo "Certificate request already exists: ${csr}"
-               fi
-               if [ ! -f ${cert} ]; then
-                       einfo "Generating self-signed certificate: ${cert}"
-                       openssl x509 -in ${csr} -out ${cert} -signkey ${privkey} || die
-               else
-                       einfo "Self-signed certifcate already exists: ${cert}"
-               fi
-               einfo "Setting permissions"
-               partimagesslperms || die
-               einfo "Done"
-       else
-               einfo "SSL is disabled, not building certificates"
-       fi
-}
-
-partimagesslperms() {
-       local ret=0
-       chmod 600 ${privkey} 2>/dev/null
-       ret=$((${ret}+$?))
-       chown partimag:0 ${privkey} 2>/dev/null
-       ret=$((${ret}+$?))
-       chmod 644 ${cert} ${csr} 2>/dev/null
-       ret=$((${ret}+$?))
-       chown root:0 ${cert} ${csr} 2>/dev/null
-       ret=$((${ret}+$?))
-       return $ret
-}
-
-pkg_postinst() {
-       if use ssl; then
-               einfo "To create the required SSL certificates, please do:"
-               einfo "emerge  --config =${PF}"
-               partimagesslperms
-               return 0
-       fi
-       chown partimag:0 "${EROOT}"/etc/partimaged/partimagedusers || die
-}