dev-ml/zarith: bump to 1.6
authorAlexis Ballier <aballier@gentoo.org>
Thu, 28 Sep 2017 08:41:07 +0000 (10:41 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 28 Sep 2017 08:41:07 +0000 (10:41 +0200)
Package-Manager: Portage-2.3.10, Repoman-2.3.3

dev-ml/zarith/Manifest
dev-ml/zarith/zarith-1.6.ebuild [new file with mode: 0644]

index f4ded9b4cc60e46eb9771c23b73eb3dc667ef548..a5fd6576decda50ee4c4b170c61150e2269aebf3 100644 (file)
@@ -1,2 +1,3 @@
 DIST zarith-1.4.1.tgz 88831 SHA256 23b6c140aad25385bb0b862b9b9fe8a5c6e6f608d0fac7a688aaede5ea876650 SHA512 ef6717e3b6c19ef94fb0e02eb33b1d9f2b2103a9fe0334cb89b01b344ee953fbeeaed8a75b17daa32760faaf93d582e6778ae50e59e9cf878663f2ecba1d5659 WHIRLPOOL 51fc093160ccd5b26282dc1e4f0da223cf0de49c357d560c45bf839ae1dadc53968b117f6ecb96da722fcda2c669ececbd6ca3fab61c71059f37764bfc602888
 DIST zarith-1.5.tar.gz 89211 SHA256 b1d7b7394267a40c933d387131004cf0bc0dbdaea7a981fce865e1ae5d12e40b SHA512 4e616b8cc81cd83f51696926e598be3bcda0bb5999db3cf42dd627cf537320a0216c74eb14c57e57fc21c909df8ef3fb3fa602a7ad633c115d2ee61af5a9fdcd WHIRLPOOL 5f99fc525cd54167f8a6188adf8398003e8728ea9fc04b338dd69a2b0c5cbc943b79b9a5dccc41f7e24a62b00ed9900843a8eca124ab652f6c99240d6620bbdb
+DIST zarith-1.6.tar.gz 89353 SHA256 0ad52b7e8d3791d401a5d64d6f85333d096b32d3ebb9f92e2496fbe64574078e SHA512 a12eacfaa809885f2b0f09ed0fc56d90ebaf9a3d8685db8a41dcaaaa2a9d2410ec96529d8bee653343ea8d51304861dbcf12daba06206a6cf07753ad3b09780d WHIRLPOOL 61f963dadeac8cc1eaef4f783957a34fa6a3507f108c26690fb7ac2aee02744f58b2e2457222d1db937f7d79eca13cbb1cdebfd795f7e3868021c737979e93f1
diff --git a/dev-ml/zarith/zarith-1.6.ebuild b/dev-ml/zarith/zarith-1.6.ebuild
new file mode 100644 (file)
index 0000000..857c502
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils toolchain-funcs
+
+DESCRIPTION="Arithmetic and logic operations over arbitrary-precision integers"
+HOMEPAGE="https://github.com/ocaml/Zarith"
+SRC_URI="https://github.com/ocaml/Zarith/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc mpir +ocamlopt"
+
+RDEPEND="
+       >=dev-lang/ocaml-4:=[ocamlopt?]
+       !mpir? ( dev-libs/gmp:0= )
+       mpir? ( sci-libs/mpir )"
+
+DEPEND="${RDEPEND} dev-lang/perl"
+
+S="${WORKDIR}/Zarith-release-${PV}"
+
+src_configure() {
+       tc-export CC
+       ./configure -host "${CHOST}" \
+               -ocamllibdir "/usr/$(get_libdir)" \
+               -installdir "${ED}/usr/$(get_libdir)/ocaml" \
+               $(usex mpir "-mpir" "-gmp") || die
+}
+
+src_compile() {
+       emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) all
+       use doc && emake doc
+}
+
+src_test() {
+       if use ocamlopt ; then
+               emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) tests
+       else
+               ewarn "Tests require USE=ocamlopt. Skipping them."
+       fi
+}
+
+src_install() {
+       findlib_src_preinst
+       emake HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) install
+       dodoc Changes README.md
+       use doc && dohtml html/*
+}