dev-go/go-text: remove old snapshot
authorWilliam Hubbs <williamh@gentoo.org>
Mon, 10 Aug 2015 19:58:15 +0000 (14:58 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 10 Aug 2015 20:07:28 +0000 (15:07 -0500)
dev-go/go-text/Manifest
dev-go/go-text/go-text-0_pre20150604.ebuild [deleted file]

index 691a67cbcd2d264c2f490953ed432d832142bcb9..522235cf6e3f54b0a5fac4a94a778b037addf2ec 100644 (file)
@@ -1,2 +1 @@
-DIST go-text-0_pre20150604.tar.gz 3719061 SHA256 71017417b42ea4e68ac77303782c83b627bfbceed041a1467ddc6319c78923ad SHA512 1bbc5bff271243ee31e346a79abf9dd128907cea82fa1eaba11be62780bd1f6b6b76a2ae9476fbe350224f450e75d12efcffd67521b49d6bec44ce2bb085f0d3 WHIRLPOOL e953d99d661537c8838757ae507f2adda3319ef22ce687a39533351201c5bb7206701db4b54f7c0e4d6df803b378a4f587a2015646825b4c3dfad97696baed2e
 DIST go-text-0_pre20150806.tar.gz 3736536 SHA256 377d3a95ffb01cf301e1b6050b1437f576f6bbfe32b6d97afc343bb0570b141f SHA512 dd0fc8b5abdfa6f005316bb7828c03a081485e0bd33cbf86c0b83f8bf9240973a7b0a2e6f52ef75f48ec00fc922be21a6c65ff9eb4080f28cb3f280bd4c4f5c6 WHIRLPOOL 79b6233c99984b98b5e74915029117e1f920e17789033ce2656d1590fbeafd4c69d145adeff7c57b1c7f8836397466461744959557877d27fc831da97a62b6ff
diff --git a/dev-go/go-text/go-text-0_pre20150604.ebuild b/dev-go/go-text/go-text-0_pre20150604.ebuild
deleted file mode 100644 (file)
index f89899e..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-KEYWORDS="~amd64"
-DESCRIPTION="Go text processing support"
-MY_PN=${PN##*-}
-GO_PN=golang.org/x/${MY_PN}
-HOMEPAGE="https://godoc.org/${GO_PN}"
-EGIT_COMMIT="df923bbb63f8ea3a26bb743e2a497abd0ab585f7"
-SRC_URI="https://github.com/golang/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-DEPEND=">=dev-lang/go-1.4"
-RDEPEND=""
-S="${WORKDIR}/src/${GO_PN}"
-EGIT_CHECKOUT_DIR="${S}"
-STRIP_MASK="*.a"
-
-src_unpack() {
-       default
-       mkdir -p src/${GO_PN%/*} || die
-       mv ${MY_PN}-${EGIT_COMMIT} src/${GO_PN} || die
-}
-
-src_compile() {
-       # Create a writable GOROOT in order to avoid sandbox violations.
-       GOROOT="${WORKDIR}/goroot"
-       cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
-       rm -rf "${GOROOT}/src/${GO_PN}" \
-               "${GOROOT}/pkg/linux_${ARCH}/${GO_PN}" || die
-       GOROOT="${GOROOT}" GOPATH=${WORKDIR} go install -v -x -work ${GO_PN}/... || die
-}
-
-src_test() {
-       # Create go symlink for TestLinking in display/dict_test.go
-       mkdir -p "${GOROOT}/bin"
-       ln -s /usr/bin/go  "${GOROOT}/bin/go" || die
-
-       GOROOT="${GOROOT}" GOPATH=${WORKDIR} \
-               go test -x -v ${GO_PN}/... || die $?
-}
-
-src_install() {
-       exeinto /usr/lib/go/bin
-       doexe "${WORKDIR}"/bin/*
-       insinto /usr/lib/go
-       find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
-       insopts -m0644 -p # preserve timestamps for bug 551486
-       doins -r "${WORKDIR}"/{pkg,src}
-}