dev-libs/libudfread: Read UDF from raw devices and image files
authorCraig Andrews <candrews@gentoo.org>
Sat, 11 Apr 2020 03:35:25 +0000 (23:35 -0400)
committerCraig Andrews <candrews@gentoo.org>
Sat, 11 Apr 2020 19:58:51 +0000 (15:58 -0400)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-libs/libudfread/Manifest [new file with mode: 0644]
dev-libs/libudfread/libudfread-1.0.0.ebuild [new file with mode: 0644]
dev-libs/libudfread/libudfread-9999.ebuild [new file with mode: 0644]
dev-libs/libudfread/metadata.xml [new file with mode: 0644]

diff --git a/dev-libs/libudfread/Manifest b/dev-libs/libudfread/Manifest
new file mode 100644 (file)
index 0000000..431e793
--- /dev/null
@@ -0,0 +1 @@
+DIST libudfread-1.0.0.tar.gz 31420 BLAKE2B bf68560d283fb88af54ee1a939166e68df94d60f1e8d3fc0d0e6e1d0faa0b9ef35825ff8a2dbbcdbfb0412dbe6e1639a34b844c10cf7424a659f974a53b59b2c SHA512 8b48d809197f3e9e4271755acffe74849aa3a01c6b23eab3acad6c2bb0c9045491f43657953300e5f84b27e99715ea2a2c4926f1120b3f5129042703c2804606
diff --git a/dev-libs/libudfread/libudfread-1.0.0.ebuild b/dev-libs/libudfread/libudfread-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..b330406
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://code.videolan.org/videolan/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://code.videolan.org/videolan/libudfread/-/archive/${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Library for reading UDF from raw devices and image files"
+HOMEPAGE="https://code.videolan.org/videolan/libudfread/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf
+}
diff --git a/dev-libs/libudfread/libudfread-9999.ebuild b/dev-libs/libudfread/libudfread-9999.ebuild
new file mode 100644 (file)
index 0000000..b330406
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://code.videolan.org/videolan/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="https://code.videolan.org/videolan/libudfread/-/archive/${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Library for reading UDF from raw devices and image files"
+HOMEPAGE="https://code.videolan.org/videolan/libudfread/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf
+}
diff --git a/dev-libs/libudfread/metadata.xml b/dev-libs/libudfread/metadata.xml
new file mode 100644 (file)
index 0000000..5a4b1cb
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>candrews@gentoo.org</email>
+    <name>Craig Andrews</name>
+  </maintainer>
+</pkgmetadata>