net-misc/dhcpcd: 6.11.5 version bump
authorWilliam Hubbs <williamh@gentoo.org>
Sun, 9 Oct 2016 15:17:11 +0000 (10:17 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Sun, 9 Oct 2016 15:18:02 +0000 (10:18 -0500)
Package-Manager: portage-2.3.0

net-misc/dhcpcd/Manifest
net-misc/dhcpcd/dhcpcd-6.11.5.ebuild [new file with mode: 0644]

index 57bb1eb02caa90d17b3319d33177084283d1e804..a6403af2bcdf482428e496f49f0b52535976665a 100644 (file)
@@ -1,3 +1,4 @@
 DIST dhcpcd-6.10.1.tar.xz 180112 SHA256 284abf8c3be0580bbac5eaca95359346ab0d78d4072317b6ce87cc68f2e8ae7b SHA512 f323c155cff47f21dde181c216408b79f10e6ed923aa3d1f3482feff47a1e88e02193ec82f831da4ef63d3703ca1837715c36a47cf3f5d09f117f6eb53bfcf67 WHIRLPOOL 805e8a1b4dad400825197dae7918a2172093d152986d5d97f4d1993f2c27cf3fbe097a5dc4f7a5292e98676b5d7fad6079ed64e4bffabeb7ccf9d91f4db80de9
 DIST dhcpcd-6.11.1.tar.xz 190956 SHA256 5c823d607ed1d7513d16ec51c54e21657f1324899e0ba333a497682d88a8c6ee SHA512 50ef755b13a96fe484623d9f2dbd91407fbea5ca728fd05dbf4259a61611a07cf3ffad7e8d20ecd513dbef80602074809abd1f5177daaa51ceccc2af5c88269f WHIRLPOOL a32350beee83184fc9d0dec5cd65f265a83aa95177b8ff700fcce2aaf2ac6c2600c322e3d8c65f1d2e9d3a2cbe71bc00b3a6efbf045fa9c805b76a3a1fca0de5
 DIST dhcpcd-6.11.3.tar.xz 194892 SHA256 5abd12c4df2947d608f60a35227f9bf8ae8ab9de06ce975cdab1144d8f229b06 SHA512 249185532cb239124f847c28e6bfb3e8a85e818e05a07eb0c6ac6843fbbab8afa8d6ebce4032b3537ccfb7fafb306dd0dc51c0e97f337f12f5071ba499686a70 WHIRLPOOL 66eebad0ceabf07324f41b7c5861b13f233d6cf3fb4f7c82804b6391594595cda8c981cec088aa75242a04614a7228be7400171d32c68ee6be354bf976a237d5
+DIST dhcpcd-6.11.5.tar.xz 198080 SHA256 6f9674dc7e27e936cc787175404a6171618675ecfb6903ab9887b1b66a87d69e SHA512 a23d5dde66567c4addbc86c8b3fbf2c5d4dba3b463659729778a310306ab0e949be8998154ef15401ac2d289bde2f090d44492bba6a1becd2f01890d4efe7051 WHIRLPOOL 1b4bdd56112db20a0c6b0c843549f7c9cd8c534a9353df026d2c63a4b4bfd624f7fbc68282e04fd4f4c7c257d996e5019d3aa624f01b532074311d63b151164f
diff --git a/net-misc/dhcpcd/dhcpcd-6.11.5.ebuild b/net-misc/dhcpcd/dhcpcd-6.11.5.ebuild
new file mode 100644 (file)
index 0000000..0b616f0
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]]; then
+       FOSSIL_URI="http://roy.marples.name/projects/dhcpcd"
+else
+       MY_P="${P/_alpha/-alpha}"
+       MY_P="${MY_P/_beta/-beta}"
+       MY_P="${MY_P/_rc/-rc}"
+       SRC_URI="http://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+       S="${WORKDIR}/${MY_P}"
+fi
+
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
+HOMEPAGE="http://roy.marples.name/projects/dhcpcd/"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"
+
+COMMON_DEPEND="udev? ( virtual/udev )"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+if [[ ${PV} == "9999" ]]; then
+       DEPEND+=" dev-vcs/fossil"
+
+       src_unpack()
+       {
+               local distdir=${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}
+               local repo=${distdir}/fossil/${PN}.fossil
+
+               addwrite "${distdir}"
+
+               if [[ -e "${repo}" ]]; then
+                       fossil pull "${FOSSIL_URI}" -R "${repo}" || die
+               else
+                       mkdir -p "${distdir}/fossil" || die
+                       fossil clone "${FOSSIL_URI}" "${repo}" || die
+               fi
+
+               mkdir -p "${S}" || die
+               cd "${S}" || die
+               fossil open "${repo}" || die
+       }
+fi
+
+src_configure()
+{
+       local dev hooks rundir
+       use udev || dev="--without-dev --without-udev"
+       hooks="--with-hook=ntp.conf"
+       use elibc_glibc && hooks="${hooks} --with-hook=yp.conf"
+       use kernel_linux && rundir="--rundir=${EPREFIX}/run"
+       econf \
+               --prefix="${EPREFIX}" \
+               --libexecdir="${EPREFIX}/lib/dhcpcd" \
+               --dbdir="${EPREFIX}/var/lib/dhcpcd" \
+               --localstatedir="${EPREFIX}/var" \
+               ${rundir} \
+               $(use_enable embedded) \
+               $(use_enable ipv6) \
+               ${dev} \
+               CC="$(tc-getCC)" \
+               ${hooks}
+}
+
+src_install()
+{
+       default
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_postinst()
+{
+       # Upgrade the duid file to the new format if needed
+       local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+       local new_duid="${ROOT}"/etc/dhcpcd.duid
+       if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+               sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+       fi
+
+       # Move the duid to /etc, a more sensible location
+       if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+               cp -p "${old_duid}" "${new_duid}"
+       fi
+
+       if [ -z "$REPLACING_VERSIONS" ]; then
+               elog
+        elog "dhcpcd has zeroconf support active by default."
+               elog "This means it will always obtain an IP address even if no"
+               elog "DHCP server can be contacted, which will break any existing"
+               elog "failover support you may have configured in your net configuration."
+               elog "This behaviour can be controlled with the noipv4ll configuration"
+               elog "file option or the -L command line switch."
+               elog "See the dhcpcd and dhcpcd.conf man pages for more details."
+
+               elog
+               elog "Dhcpcd has duid enabled by default, and this may cause issues"
+               elog "with some dhcp servers. For more information, see"
+               elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
+       fi
+
+       if ! has_version net-dns/bind-tools; then
+               elog
+               elog "If you activate the lookup-hostname hook to look up your hostname"
+               elog "using the dns, you need to install net-dns/bind-tools."
+       fi
+}