dev-python/networkx: Add python3 support for pygraphviz
authorJustin Lecher <jlec@gentoo.org>
Mon, 7 Sep 2015 07:29:28 +0000 (09:29 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 7 Sep 2015 07:33:38 +0000 (09:33 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/networkx/networkx-1.10.ebuild

index 95ff6a288d1d2930314c678c4f3c588bc984d5eb..23f88cc5a38530526d94947b1ce1034469a1447c 100644 (file)
@@ -17,7 +17,8 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="doc examples test"
 
-COMMON_DEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+COMMON_DEPEND="
+       dev-python/matplotlib[${PYTHON_USEDEP}]
                sci-libs/scipy[${PYTHON_USEDEP}]"
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
@@ -36,7 +37,7 @@ RDEPEND="
        >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
        examples? (
                ${COMMON_DEPEND}
-               $(python_gen_cond_dep 'dev-python/pygraphviz[${PYTHON_USEDEP}]' python2_7)
+               dev-python/pygraphviz[${PYTHON_USEDEP}]
                dev-python/pyparsing[${PYTHON_USEDEP}]
                dev-python/pyyaml[${PYTHON_USEDEP}]
        )"