sys-fs/zfs: drop 0.8.2
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 30 Mar 2020 19:14:34 +0000 (12:14 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 30 Mar 2020 21:07:45 +0000 (14:07 -0700)
Closes: https://bugs.gentoo.org/706534
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
sys-fs/zfs/Manifest
sys-fs/zfs/files/0.8.2-ZPOOL_IMPORT_UDEV_TIMEOUT_MS.patch [deleted file]
sys-fs/zfs/zfs-0.8.2-r2.ebuild [deleted file]

index 84cfb1d2a3e7a8998f5a7bafb4cb4a715e1f3766..5de6d1f5c7741dfe7844dc25703d130a379aadf4 100644 (file)
@@ -1,3 +1,2 @@
 DIST zfs-0.7.13.tar.gz 6614047 BLAKE2B c59c46287715779eb04d69333b0a417fa9865eb0d61c642b043188c4c97d4eed369f76a48327326ed1d4dd608ff95d91d20d26c80ed0b120a8fcd5f83cea638f SHA512 457d8f110b68c9656194cd3738b216d5d807d680e5cfc6ed1f3cf5ebde67860476387c6b862ba3ba7f972d8945075963e6c325543ab84468e3eff5dbce68476e
-DIST zfs-0.8.2.tar.gz 8738111 BLAKE2B 5c15f6664ca70f0deeb5b9e32f2bcff68f9821529e5203ff18612ce88473fee9af369354c442f3db7882d301cf17c805c9635b05bfd3460833ed8e5ff8004dd0 SHA512 1424b1a030b814f812b5da422100669db5b8c3ccae14c2fdd62a5e0df28e7255247fe5ca99c95a14f08c92cc1574c22dd132093e4a1dd81e38c95b10cc5e2496
 DIST zfs-0.8.3.tar.gz 8779385 BLAKE2B 8b51b9d5b61543566bc7839d8452fdf9358442155e95f93a011531338824bbd4fc8879500e276b02d5d49d504a046728ecc0c6154f69eb7b47180b9bb0e46958 SHA512 aded632e6b04180560d4f2ff283260016e883dadae4e7fda9070b7113dee948099cb7a7b183f1c8139654389a2610fb9cc6f997acdc846040e605125cf016010
diff --git a/sys-fs/zfs/files/0.8.2-ZPOOL_IMPORT_UDEV_TIMEOUT_MS.patch b/sys-fs/zfs/files/0.8.2-ZPOOL_IMPORT_UDEV_TIMEOUT_MS.patch
deleted file mode 100644 (file)
index 00dda6d..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-From 803884217f9b9b5fb235d7c5e78a809d271f6387 Mon Sep 17 00:00:00 2001
-From: Richard Yao <ryao@gentoo.org>
-Date: Wed, 9 Oct 2019 12:16:12 -0700
-Subject: [PATCH] Implement ZPOOL_IMPORT_UDEV_TIMEOUT_MS
-
-Since 0.7.0, zpool import would unconditionally block on udev for 30
-seconds. This introduced a regression in initramfs environments that
-lack udev (particularly mdev based environments), yet use a zfs userland
-tools intended for the system that had been built against udev. Gentoo's
-genkernel is the main example, although custom user initramfs
-environments would be similarly impacted unless special builds of the
-ZFS userland utilities were done for them.  Such environments already
-have their own mechanisms for blocking until device nodes are ready
-(such as genkernel's scandelay parameter), so it is unnecessary for
-zpool import to block on a non-existent udev until a timeout is reached
-inside of them.
-
-Rather than trying to intelligently determine whether udev is available
-on the system to avoid unnecessarily blocking in such environments, it
-seems best to just allow the environment to override the timeout.  I
-propose that we add an environment variable called
-ZPOOL_IMPORT_UDEV_TIMEOUT_MS. Setting it to 0 would restore the 0.6.x
-behavior that was more desirable in mdev based initramfs environments.
-This allows the system user land utilities to be reused when building
-mdev-based initramfs archives.
-
-Reviewed-by: Igor Kozhukhov <igor@dilos.org>
-Reviewed-by: Jorgen Lundman <lundman@lundman.net>
-Reviewed-by: Brian Behlendorf <behlendorf1@llnl.gov>
-Reviewed-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-Signed-off-by: Richard Yao <ryao@gentoo.org>
-Closes #9436
----
- lib/libzutil/os/linux/zutil_import_os.c | 11 ++++++++++-
- man/man8/zpool.8                        |  6 ++++++
- 2 files changed, 16 insertions(+), 1 deletion(-)
-
-diff --git a/lib/libzutil/zutil_import.c b/lib/libzutil/zutil_import.c
-index 811eae397c9..e51004edc68 100644
---- a/lib/libzutil/zutil_import.c
-+++ b/lib/libzutil/zutil_import.c
-@@ -53,6 +53,7 @@
- #include <libgen.h>
- #include <stddef.h>
- #include <stdlib.h>
-+#include <stdio.h>
- #include <string.h>
- #include <sys/stat.h>
- #include <unistd.h>
-@@ -181,17 +182,25 @@ zpool_open_func(void *arg)
-       if (rn->rn_labelpaths) {
-               char *path = NULL;
-               char *devid = NULL;
-+              char *env = NULL;
-               rdsk_node_t *slice;
-               avl_index_t where;
-+              int timeout;
-               int error;
-               if (label_paths(rn->rn_hdl, rn->rn_config, &path, &devid))
-                       return;
-+              env = getenv("ZPOOL_IMPORT_UDEV_TIMEOUT_MS");
-+              if ((env == NULL) || sscanf(env, "%d", &timeout) != 1 ||
-+                  timeout < 0) {
-+                      timeout = DISK_LABEL_WAIT;
-+              }
-+
-               /*
-                * Allow devlinks to stabilize so all paths are available.
-                */
--              zpool_label_disk_wait(rn->rn_name, DISK_LABEL_WAIT);
-+              zpool_label_disk_wait(rn->rn_name, timeout);
-               if (path != NULL) {
-                       slice = zutil_alloc(hdl, sizeof (rdsk_node_t));
-diff --git a/man/man8/zpool.8 b/man/man8/zpool.8
-index 467d2411d40..df30b7ca05c 100644
---- a/man/man8/zpool.8
-+++ b/man/man8/zpool.8
-@@ -2813,6 +2813,12 @@ Similar to the
- option in
- .Nm zpool import .
- .El
-+.Bl -tag -width "ZPOOL_IMPORT_UDEV_TIMEOUT_MS"
-+.It Ev ZPOOL_IMPORT_UDEV_TIMEOUT_MS
-+The maximum time in milliseconds that
-+.Nm zpool import
-+will wait for an expected device to be available.
-+.El
- .Bl -tag -width "ZPOOL_VDEV_NAME_GUID"
- .It Ev ZPOOL_VDEV_NAME_GUID
- Cause
diff --git a/sys-fs/zfs/zfs-0.8.2-r2.ebuild b/sys-fs/zfs/zfs-0.8.2-r2.ebuild
deleted file mode 100644 (file)
index c744e61..0000000
+++ /dev/null
@@ -1,224 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit bash-completion-r1 flag-o-matic linux-info linux-mod distutils-r1 systemd toolchain-funcs udev usr-ldscript
-
-DESCRIPTION="Userland utilities for ZFS Linux kernel module"
-HOMEPAGE="https://zfsonlinux.org/"
-
-if [[ ${PV} == "9999" ]] ; then
-       inherit autotools git-r3
-       EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
-else
-       SRC_URI="https://github.com/zfsonlinux/${PN}/releases/download/${P}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm64 ~ppc64"
-fi
-
-LICENSE="BSD-2 CDDL MIT"
-SLOT="0"
-IUSE="custom-cflags debug kernel-builtin libressl python +rootfs test-suite static-libs"
-
-DEPEND="
-       ${PYTHON_DEPS}
-       net-libs/libtirpc[static-libs?]
-       sys-apps/util-linux[static-libs?]
-       sys-libs/zlib[static-libs(+)?]
-       virtual/awk
-       virtual/libudev[static-libs(-)?]
-       libressl? ( dev-libs/libressl:0=[static-libs?] )
-       !libressl? ( dev-libs/openssl:0=[static-libs?] )
-       python? (
-               virtual/python-cffi[${PYTHON_USEDEP}]
-       )
-"
-
-BDEPEND="virtual/awk
-       virtual/pkgconfig
-       python? (
-               dev-python/setuptools[${PYTHON_USEDEP}]
-       )
-"
-
-RDEPEND="${DEPEND}
-       !=sys-apps/grep-2.13*
-       !kernel-builtin? ( ~sys-fs/zfs-kmod-${PV} )
-       !sys-fs/zfs-fuse
-       !prefix? ( virtual/udev )
-       sys-fs/udev-init-scripts
-       rootfs? (
-               app-arch/cpio
-               app-misc/pax-utils
-               !<sys-boot/grub-2.00-r2:2
-               !<sys-kernel/genkernel-3.5.1.1
-               !<sys-kernel/genkernel-next-67
-               !<sys-kernel/bliss-initramfs-7.1.0
-               !<sys-kernel/dracut-044-r1
-       )
-       test-suite? (
-               sys-apps/util-linux
-               sys-devel/bc
-               sys-block/parted
-               sys-fs/lsscsi
-               sys-fs/mdadm
-               sys-process/procps
-               virtual/modutils
-       )
-"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RESTRICT="test"
-
-PATCHES=(
-       "${FILESDIR}/bash-completion-sudo.patch"
-       "${FILESDIR}/0.8.2-ZPOOL_IMPORT_UDEV_TIMEOUT_MS.patch" # https://github.com/zfsonlinux/zfs/pull/9109
-)
-
-pkg_setup() {
-       if use kernel_linux && use test-suite; then
-               linux-info_pkg_setup
-
-               if  ! linux_config_exists; then
-                       ewarn "Cannot check the linux kernel configuration."
-               else
-                       if use test-suite; then
-                               if linux_chkconfig_present BLK_DEV_LOOP; then
-                                       eerror "The ZFS test suite requires loop device support enabled."
-                                       eerror "Please enable it:"
-                                       eerror "    CONFIG_BLK_DEV_LOOP=y"
-                                       eerror "in /usr/src/linux/.config or"
-                                       eerror "    Device Drivers --->"
-                                       eerror "        Block devices --->"
-                                       eerror "            [X] Loopback device support"
-                               fi
-                       fi
-               fi
-       fi
-}
-
-src_prepare() {
-       default
-
-       if [[ ${PV} == "9999" ]]; then
-               eautoreconf
-       else
-               # Set revision number
-               sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
-       fi
-
-       if use python; then
-               pushd contrib/pyzfs >/dev/null || die
-               distutils-r1_src_prepare
-               popd >/dev/null || die
-       fi
-
-       # prevent errors showing up on zfs-mount stop, #647688
-       # openrc will unmount all filesystems anyway.
-       sed -i "/^ZFS_UNMOUNT=/ s/yes/no/" etc/init.d/zfs.in || die
-}
-
-src_configure() {
-       use custom-cflags || strip-flags
-       python_setup
-
-       local myconf=(
-               --bindir="${EPREFIX}/bin"
-               --enable-shared
-               --enable-systemd
-               --enable-sysvinit
-               --localstatedir="${EPREFIX}/var"
-               --sbindir="${EPREFIX}/sbin"
-               --with-config=user
-               --with-dracutdir="${EPREFIX}/usr/lib/dracut"
-               --with-linux="${KV_DIR}"
-               --with-linux-obj="${KV_OUT_DIR}"
-               --with-udevdir="$(get_udevdir)"
-               --with-python="${EPYTHON}"
-               --with-systemdunitdir="$(systemd_get_systemunitdir)"
-               --with-systemdpresetdir="${EPREFIX}/lib/systemd/system-preset"
-               $(use_enable debug)
-               $(use_enable python pyzfs)
-               $(use_enable static-libs static)
-       )
-
-       econf "${myconf[@]}"
-}
-
-src_compile() {
-       default
-       if use python; then
-               pushd contrib/pyzfs >/dev/null || die
-               distutils-r1_src_compile
-               popd >/dev/null || die
-       fi
-}
-
-src_install() {
-       default
-
-       gen_usr_ldscript -a uutil nvpair zpool zfs zfs_core
-
-       use test-suite || rm -rf "${ED}/usr/share/zfs"
-
-       if ! use static-libs; then
-               find "${ED}/" -name '*.la' -delete || die
-       fi
-
-       dobashcomp contrib/bash_completion.d/zfs
-       bashcomp_alias zfs zpool
-
-       # strip executable bit from conf.d file
-       fperms 0644 /etc/conf.d/zfs
-
-       if use python; then
-               pushd contrib/pyzfs >/dev/null || die
-               distutils-r1_src_install
-               popd >/dev/null || die
-       fi
-
-       # enforce best available python implementation
-       python_fix_shebang "${ED}/bin"
-}
-
-pkg_postinst() {
-       if use rootfs; then
-               if ! has_version sys-kernel/genkernel && ! has_version sys-kernel/dracut; then
-                       elog "root on zfs requires initramfs to boot"
-                       elog "the following packages known to provide one and tested on regular basis:"
-                       elog "  sys-kernel/dracut"
-                       elog "  sys-kernel/genkernel"
-               fi
-
-               if has_version "<=sys-kernel/genkernel-3.5.3.3"; then
-                       einfo "genkernel version 3.5.3.3 and earlier does NOT support"
-                       einfo " unlocking pools with native zfs encryption enabled at boot"
-                       einfo " use dracut or >=genkernel-4 if you requre this functionality"
-               fi
-       fi
-
-       if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then
-               einfo "Adding ${P} to the module database to ensure that the"
-               einfo "kernel modules and userland utilities stay in sync."
-               update_moduledb
-       fi
-
-       [[ -e "${EROOT}/etc/runlevels/boot/zfs-import" ]] || \
-               einfo "You should add zfs-import to the boot runlevel."
-       [[ -e "${EROOT}/etc/runlevels/boot/zfs-mount" ]]|| \
-               einfo "You should add zfs-mount to the boot runlevel."
-       [[ -e "${EROOT}/etc/runlevels/default/zfs-share" ]] || \
-               einfo "You should add zfs-share to the default runlevel."
-       [[ -e "${EROOT}/etc/runlevels/default/zfs-zed" ]] || \
-               einfo "You should add zfs-zed to the default runlevel."
-}
-
-pkg_postrm() {
-       if ! use kernel-builtin && [[ ${PV} == "9999" ]]; then
-               remove_moduledb
-       fi
-}