xfce-extra/xfce4-mpc-plugin: Bump to 0.5.2
authorMichał Górny <mgorny@gentoo.org>
Tue, 13 Aug 2019 11:20:35 +0000 (13:20 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 13 Aug 2019 12:10:43 +0000 (14:10 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-extra/xfce4-mpc-plugin/Manifest
xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild [new file with mode: 0644]

index d150105694c9ae81d3d327f163726bd4689b5f2f..052ff8d9ced178e0dbfa4fe0833f9b53592d0c65 100644 (file)
@@ -1 +1,2 @@
 DIST xfce4-mpc-plugin-0.5.1.tar.bz2 290830 BLAKE2B 464bf4e3ca12049d241ddbf5cd2e30e4e41bda2934e809f8c75f2ceaa659647918d90a6265a49d01f84e2d0d3a6cca880ee8c90dcbf377a163e14fcfe25e5ae0 SHA512 7647ecdc7058e67be26c615853059cba25944fc6e31b06bca1e48f5378d3afddc2c4b82c5c581fe8ec716e0723a4d65c7ec4ee592540936ccca331049b3e024c
+DIST xfce4-mpc-plugin-0.5.2.tar.bz2 293655 BLAKE2B 0b82ee0c8d19342365d6e7a7fc28fcc4ccf880c735df70e793123e63ff86df7e6c3d6d80a8b1c81dd4f7fb264a291897a1900c76aef35c4855c333c85ddfc467 SHA512 c0e6580d5c9c8677a1ad4e8ec4233de1aafc8a2e6744d5d82d3f58f5689e53096a40ff0d1355475a0fdb3e6bc54b44aabb9ca91e5e9caf5cf3ef6fdd4778c22e
diff --git a/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild b/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.5.2.ebuild
new file mode 100644 (file)
index 0000000..835a3b9
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Music Player Daemon (mpd) panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-mpc-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+libmpd"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+       >=xfce-base/xfce4-panel-4.13.5:=
+       libmpd? ( media-libs/libmpd:= )"
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       virtual/pkgconfig"
+
+src_configure() {
+       econf $(use_enable libmpd)
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}