app-emulation/docker-compose: Remove old (vuln. pyyaml)
authorMichał Górny <mgorny@gentoo.org>
Fri, 20 Mar 2020 09:03:41 +0000 (10:03 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 20 Mar 2020 09:03:41 +0000 (10:03 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-emulation/docker-compose/Manifest
app-emulation/docker-compose/docker-compose-1.24.0.ebuild [deleted file]
app-emulation/docker-compose/docker-compose-1.25.4.ebuild [deleted file]
app-emulation/docker-compose/files/docker-compose-1.24.0-setup-py.patch [deleted file]

index 619bd7b61cbb27027ec31d1f4a24529372125b23..27ce8954a3c3d142dd5e19ab69aa36c29ed39d9a 100644 (file)
@@ -1,2 +1 @@
-DIST docker-compose-1.24.0.tar.gz 307601 BLAKE2B cb2a6f96e14c04d0279b25c075182d8f09e5a622e4cee2ce74995224e3a8634cc5f22ccc548b7754bbeb11630c1e638386cb1a6df927b3619cb6e7e3595aac6c SHA512 318c6bf9877147de09526b4d49c3fd86012d85626e7a9a15863ca55a60e10fa85b27429605045d0aaa993dddd3bc2e5f23cbb76856276a874e84793b878a3e86
 DIST docker-compose-1.25.4.tar.gz 306513 BLAKE2B 86c779d794deca7ede0adc80041b17a96b21798d2807065e2c9ea804a95fcaf24a8b92fbcad6c7ce4d1b9d1fb3c9ad348b630e3f10bfd032202995a4c34ab019 SHA512 860153fb603d7efcc76535c9997446a2e6fe18f61769d4f05f51b531902a66072be11e3cff012ba80240b0a7802a032495a2a55e053a9784df92b82e5351b72e
diff --git a/app-emulation/docker-compose/docker-compose-1.24.0.ebuild b/app-emulation/docker-compose/docker-compose-1.24.0.ebuild
deleted file mode 100644 (file)
index 96eaada..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 2018-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Multi-container orchestration for Docker"
-HOMEPAGE="https://github.com/docker/compose"
-SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
-       >=dev-python/docker-py-3.7.0[${PYTHON_USEDEP}]
-       >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
-       >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
-       >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
-       dev-python/paramiko[${PYTHON_USEDEP}]
-       >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.18.1[${PYTHON_USEDEP}]
-       >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
-       >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}
-       test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
-               <dev-python/pyyaml-5.1[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/compose-${PV}"
-
-PATCHES=(
-       # Bug #679968 -- https://bugs.gentoo.org/679968
-       # Bug #681002 -- https://bugs.gentoo.org/681002
-       "${FILESDIR}"/${PN}-1.24.0-setup-py.patch
-)
-
-src_prepare() {
-       # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
-       sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
-
-       default
-}
-
-python_test() {
-       distutils_install_for_testing
-       ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       newbashcomp contrib/completion/bash/docker-compose ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       doins contrib/completion/zsh/*
-
-       distutils-r1_python_install_all
-}
diff --git a/app-emulation/docker-compose/docker-compose-1.25.4.ebuild b/app-emulation/docker-compose/docker-compose-1.25.4.ebuild
deleted file mode 100644 (file)
index 7fd5d94..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2018-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Multi-container orchestration for Docker"
-HOMEPAGE="https://github.com/docker/compose"
-SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
-       >=dev-python/docker-py-3.7.0[${PYTHON_USEDEP}]
-       >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
-       >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
-       >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
-       dev-python/paramiko[${PYTHON_USEDEP}]
-       >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
-       >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
-       >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]"
-
-DEPEND="${RDEPEND}
-       test? (
-               <dev-python/pytest-4[${PYTHON_USEDEP}]
-               dev-python/ddt[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}/compose-${PV}"
-
-PATCHES=(
-       # Bug #679968 -- https://bugs.gentoo.org/679968
-       # Bug #681002 -- https://bugs.gentoo.org/681002
-       "${FILESDIR}"/${PN}-1.25.2-setup-py.patch
-)
-
-src_prepare() {
-       # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
-       sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
-
-       default
-}
-
-python_test() {
-       distutils_install_for_testing
-       ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       newbashcomp contrib/completion/bash/docker-compose ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       doins contrib/completion/zsh/*
-
-       distutils-r1_python_install_all
-}
diff --git a/app-emulation/docker-compose/files/docker-compose-1.24.0-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.24.0-setup-py.patch
deleted file mode 100644 (file)
index 1632a01..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-From 981faad5f67a843f2b6c44f40be4dc8d2c5156c7 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sat, 11 May 2019 00:32:22 +0200
-Subject: [PATCH] setup.py: Drop generic upper version boundaries
-
----
- setup.py | 26 +++++++++++++-------------
- 1 file changed, 13 insertions(+), 13 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 8371cc7..b9e5a80 100644
---- a/setup.py
-+++ b/setup.py
-@@ -30,16 +30,16 @@ def find_version(*file_paths):
- install_requires = [
--    'cached-property >= 1.2.0, < 2',
--    'docopt >= 0.6.1, < 0.7',
--    'PyYAML >= 3.10, < 4.3',
--    'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.21',
--    'texttable >= 0.9.0, < 0.10',
--    'websocket-client >= 0.32.0, < 1.0',
--    'docker[ssh] >= 3.7.0, < 4.0',
--    'dockerpty >= 0.4.1, < 0.5',
--    'six >= 1.3.0, < 2',
--    'jsonschema >= 2.5.1, < 3',
-+    'cached-property >= 1.2.0',
-+    'docopt >= 0.6.1',
-+    'PyYAML >= 3.10',
-+    'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0',
-+    'texttable >= 0.9.0',
-+    'websocket-client >= 0.32.0',
-+    'docker[ssh] >= 3.7.0',
-+    'dockerpty >= 0.4.1',
-+    'six >= 1.3.0',
-+    'jsonschema >= 2.5.1',
- ]
-@@ -52,11 +52,11 @@ if sys.version_info[:2] < (3, 4):
-     tests_require.append('mock >= 1.0.1')
- extras_require = {
--    ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
-+    ':python_version < "3.4"': ['enum34 >= 1.0.4'],
-     ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
-     ':python_version < "3.3"': ['ipaddress >= 1.0.16'],
--    ':sys_platform == "win32"': ['colorama >= 0.4, < 0.5'],
--    'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
-+    ':sys_platform == "win32"': ['colorama >= 0.4'],
-+    'socks': ['PySocks >= 1.5.6, != 1.5.7'],
- }
--- 
-2.21.0
-