app-portage/tatt: improve python handling
authorMichael Palimaka <kensington@gentoo.org>
Tue, 21 Apr 2020 09:01:22 +0000 (19:01 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Tue, 21 Apr 2020 09:01:35 +0000 (19:01 +1000)
* Add Python 3.7
* Fix dependencies

Closes: https://bugs.gentoo.org/718252
Package-Manager: Portage-2.3.89, Repoman-2.3.22
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
app-portage/tatt/tatt-0.7-r1.ebuild [new file with mode: 0644]
app-portage/tatt/tatt-9999.ebuild

diff --git a/app-portage/tatt/tatt-0.7-r1.ebuild b/app-portage/tatt/tatt-0.7-r1.ebuild
new file mode 100644 (file)
index 0000000..fd1e8f3
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="arch testing tool"
+HOMEPAGE="https://github.com/gentoo/tatt"
+SRC_URI="https://github.com/gentoo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+templates"
+
+RDEPEND="
+       app-portage/eix
+       app-portage/gentoolkit[${PYTHON_USEDEP}]
+       dev-python/configobj[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+       www-client/pybugz
+"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+       distutils-r1_python_install_all
+       if use templates; then
+               insinto "/usr/share/${PN}"
+               doins -r templates
+       fi
+       doman tatt.1
+       doman tatt.5
+}
index 15cbacda910d02c54c0918423f87d7b8f235b72e..e998e0c14c15b864eed76697fa8b264c4af2cd82 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit distutils-r1 git-r3
 
@@ -19,7 +19,7 @@ IUSE="+templates"
 
 RDEPEND="
        app-portage/eix
-       app-portage/gentoolkit
+       app-portage/gentoolkit[${PYTHON_USEDEP}]
        dev-python/configobj[${PYTHON_USEDEP}]
        dev-python/requests[${PYTHON_USEDEP}]
        www-client/pybugz