app-office/calcurse: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Tue, 10 Mar 2020 10:32:00 +0000 (11:32 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 10 Mar 2020 11:28:15 +0000 (12:28 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-office/calcurse/Manifest
app-office/calcurse/calcurse-4.5.0.ebuild [new file with mode: 0644]

index a709a800e0cf59fc29349c0943861827698cf60f..d61266faf9bb8aee38b03d3615566950cb9facf0 100644 (file)
@@ -1 +1,2 @@
 DIST calcurse-4.4.0.tar.gz 620263 BLAKE2B 8fbe875f5e757ec3c11b9c23a994260403ee990bfcb3d4c41eefbf06a6db9e76cd5157e32b11c3fdc049896d5db3a9856862724902dab1cb48e0b00ef5df6f73 SHA512 43d30ad68bb39aaa9460644a691e66cbb15b9930737581583da65d00214c70fb1148a0edeca4430abb7a5cef2821b0f4c6fdbed8188d9ea5da5fedc4f95fa07c
+DIST calcurse-4.5.0.tar.gz 657976 BLAKE2B 5cad43340cb973d402c92b7963f9c13e46acbb2f802df2ab447221913daa6b28872a323b743bc31be0c7358ea8e7d51d08054c81f3376d3dc07f5837d41be45f SHA512 795eae7c62b89c733049f0c137da398ce3dd5fba78f9a2c323aacdf8b176cf37bd9d0768dbdac0bb1cb64cd248b1d851efd059836fbbbdd9665fa47beff3b872
diff --git a/app-office/calcurse/calcurse-4.5.0.ebuild b/app-office/calcurse/calcurse-4.5.0.ebuild
new file mode 100644 (file)
index 0000000..46600ed
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+       dev-python/httplib2
+       sys-libs/ncurses:0="
+
+DEPEND="
+       ${RDEPEND}
+       doc? ( app-text/asciidoc )"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-4.2.1-tinfo.patch
+)
+
+# Most tests fail.
+RESTRICT="test"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+       multilib-minimal_src_compile
+}
+
+src_install() {
+       multilib-minimal_src_install
+}