dev-python/python-eventlib: initial import of version 0.2.1
authorJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 00:39:59 +0000 (02:39 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Tue, 8 Sep 2015 17:40:14 +0000 (19:40 +0200)
Gentoo-Bug: 446192

dev-python/python-eventlib/Manifest [new file with mode: 0644]
dev-python/python-eventlib/metadata.xml [new file with mode: 0644]
dev-python/python-eventlib/python-eventlib-0.2.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/python-eventlib/Manifest b/dev-python/python-eventlib/Manifest
new file mode 100644 (file)
index 0000000..6ce51e6
--- /dev/null
@@ -0,0 +1 @@
+DIST python-eventlib-0.2.1.tar.gz 189314 SHA256 25224794420f430946fe46932718b521a6264903fe8c0ed3563dfdb844c623e7 SHA512 f1ca3c6eb54677068ec209386f09c695c141b08e148475ee3cc69e667dd96af3637a66660e9105a195620f3bde10d4b18087612c501764d52413982c2721e1a6 WHIRLPOOL a95ac7283d1425161d190c17ceb7d58ff81a3ec9aa09066226c177a4d7343c2f99ea19c7866d4a03d281241337efa877020c85956c7c81cfb0444e457fda9f9f
diff --git a/dev-python/python-eventlib/metadata.xml b/dev-python/python-eventlib/metadata.xml
new file mode 100644 (file)
index 0000000..a841434
--- /dev/null
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>python</herd>
+       <maintainer>
+               <email>hasufell@gentoo.org</email>
+               <name>Julian Ospald</name>
+       </maintainer>
+       <longdescription lang="en">
+               Eventlib is a networking library written in Python. It achieves
+               high scalability by using non-blocking io while at the same time
+               retaining high programmer usability by using coroutines to make
+               the non-blocking io operations appear blocking at the source code
+               level.
+       </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-eventlib/python-eventlib-0.2.1.ebuild b/dev-python/python-eventlib/python-eventlib-0.2.1.ebuild
new file mode 100644 (file)
index 0000000..3dab2ca
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_REQ_USE="ssl"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Coroutine-based networking library"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/SipClient/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/greenlet[${PYTHON_USEDEP}]
+       dev-python/twisted-core[${PYTHON_USEDEP}]
+"