dev-python/zipp: remove old
authorLouis Sautier <sbraz@gentoo.org>
Mon, 27 Jan 2020 13:17:59 +0000 (14:17 +0100)
committerLouis Sautier <sbraz@gentoo.org>
Wed, 29 Jan 2020 11:02:15 +0000 (12:02 +0100)
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/zipp/Manifest
dev-python/zipp/zipp-0.5.2.ebuild [deleted file]

index 5c0187528c2752f1081ec2d991f107ec368ab7f9..e72fa1dc338084750134b7d9fc158524b1ade7e3 100644 (file)
@@ -1,4 +1,3 @@
-DIST zipp-0.5.2.tar.gz 10875 BLAKE2B 97e56b8e1cbff2344ee6b385085e6c821d61bd2c2510ac54e50a3f706515f1e22789168c97599787787b47f09dabe55abb594f5724d1d540f62d8d68fc32e36f SHA512 8c84b620844315ab1f1aa3c5bb29dcdf1271a0139198b5c3d6aa31ecb9a86f0dcef963819403d971ae0461c737312c064572c57ecf32d73dc973a5f69cf0375c
 DIST zipp-0.6.0.tar.gz 10778 BLAKE2B 165ae85f51fe0c0232f6cf2dde70e2d7f8064413c15616d15e1ebd65cfe3c345bbd5b1b9713fa1171cad18015b605862509790bedd734edf5a7d8c80c5378af3 SHA512 18bef5aa3388ab3901bf08888127fc9cc17d8972a52f23ccf9a8035f09ee5598e17ddff833a10b81b2118461e0c517e88413518736763425a728cd0b19cc2052
 DIST zipp-1.0.0.tar.gz 10821 BLAKE2B f5e0476cb0ca01054abc0c56f1a9581a6f537c002791c4a363238555ce9a211fe13114041374c1bfef426544545e3c654e5b0a7e0541c30b775757c43df6d756 SHA512 dbfadfedd30ca4cb31ac4163f367134d96e57405ef00d5f4c19c0af7a141f78487dec29a0ba94975584fcb462d22c8b536bf29c67b7e298368072e897b0e9d82
 DIST zipp-2.0.1.tar.gz 12790 BLAKE2B 107079d2cbe73c4d0d7053696181d99636192374eac4598a8f2007b8197c007e90ef39a56d193052d484b36247d73d5712d878ea35d222895e5b3ff21963ba13 SHA512 ac49f0c0aa83398ad0892932b1f067df94e2108691338c80400235053834bcbcb1a58b2b7b5807f398088a09e9d1cb591d94153a2a44ef3ef96506271d817e05
diff --git a/dev-python/zipp/zipp-0.5.2.ebuild b/dev-python/zipp/zipp-0.5.2.ebuild
deleted file mode 100644 (file)
index 5bfbbf4..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
-HOMEPAGE="https://github.com/jaraco/zipp"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
-       test? (
-               dev-python/contextlib2[${PYTHON_USEDEP}]
-               dev-python/pathlib2[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/unittest2[${PYTHON_USEDEP}]
-       )
-       doc? (
-               >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
-               >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
-               dev-python/sphinx[${PYTHON_USEDEP}]
-       )
-"
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs docs/_build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       pytest -vv || die "tests failed with ${EPYTHON}"
-}