dev-python/pyparsing: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Thu, 29 Oct 2015 09:22:42 +0000 (10:22 +0100)
committerJustin Lecher <jlec@gentoo.org>
Thu, 29 Oct 2015 10:43:59 +0000 (11:43 +0100)
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pyparsing/Manifest
dev-python/pyparsing/files/pyparsing-2.0.4-print.patch [new file with mode: 0644]
dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild
dev-python/pyparsing/pyparsing-2.0.3.ebuild
dev-python/pyparsing/pyparsing-2.0.4.ebuild [new file with mode: 0644]

index 263c210bc4cd64af49df2c29ed643bd6c87e9311..59fbf3f7b0982a78e0d8abfb20d568871a39cf90 100644 (file)
@@ -1,2 +1,3 @@
 DIST pyparsing-1.5.6.tar.gz 1418892 SHA256 5c84aa4500e82d5aa2c0842d5628c5da985e68ac1fb33554e0e5547eb3c85a75 SHA512 614c1a016d121b7c4ecf90a164bbe323affd6cf72319c8494e9a583078ffa233c351627fc3e793307e407e043570f8301f112c4d86645dcd130220ed976289c8 WHIRLPOOL 278d37581a950a570ac3cca2a5f8b674c909220fddc47072d9d52c38b8dfc30b335530dffd3c522cd18e58e9bddcc5e48d9184cdaf4b09203bbba308607e24a4
 DIST pyparsing-2.0.3.tar.gz 1462653 SHA256 06e729e1cbf5274703b1f47b6135ed8335999d547f9d8cf048b210fb8ebf844f SHA512 9771851f4b0191c7d3f8d2a2a6d2a9198b173120d3f133d08284b71e792fc59a906d571edea8f44ba04ab00c1d906e1974d1e8a2d6155d492de1358ba99c575a WHIRLPOOL 42b9c7aa0b8d4d91436a01a60cbca64a9c8f7798b7aeb60bd2c4af085f9e13167a5ac5132d55bd890b4890c00428e908dfae32ed78ec153c868ee02ed3cdaa3f
+DIST pyparsing-2.0.4.tar.gz 1140009 SHA256 c43c9f1395975bf2b032c20e6b149d6b698cdabf9291079bcaf0131709e95f59 SHA512 021d3610ead6b864b1e0227b6cad2393aae0c1f38a44c09dd7ac33d05be30cb4c75176a33ebd8c44e87ed9d54b58aaf27fab7ac8f3cdcb3ce4418b5b0d586b01 WHIRLPOOL 0fa3fe631c5c6fc79fb13f029fe8a32bd9651fd663e915c5be394225bcb1ea1f199d3edc2294e7a4b0732590e7a0cc3053effca9aa20155ca69d4c3908019e6d
diff --git a/dev-python/pyparsing/files/pyparsing-2.0.4-print.patch b/dev-python/pyparsing/files/pyparsing-2.0.4-print.patch
new file mode 100644 (file)
index 0000000..6262a18
--- /dev/null
@@ -0,0 +1,51 @@
+ pyparsing.py | 20 +++++++++++---------
+ 1 file changed, 11 insertions(+), 9 deletions(-)
+
+diff --git a/pyparsing.py b/pyparsing.py
+index 81c82ce..55c72a3 100644
+--- a/pyparsing.py
++++ b/pyparsing.py
+@@ -22,6 +22,8 @@
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.\r
+ #\r
\r
++from __future__ import print_function\r
++\r
+ __doc__ = \\r
+ """\r
+ pyparsing module - Classes and methods to define and execute parsing grammars\r
+@@ -1554,19 +1556,19 @@ class ParserElement(object):
+            run a parse expression against a list of sample strings.\r
+         """\r
+         for t in tests:\r
+-            print t\r
++            print(t)\r
+             try:\r
+-                print self.parseString(t).dump()\r
++                print(self.parseString(t).dump())\r
+             except ParseException as pe:\r
+                 if '\n' in t:\r
+-                    print line(pe.loc, t)\r
+-                    print ' '*(col(pe.loc,t)-1) + '^'\r
++                    print(line(pe.loc, t))\r
++                    print(' '*(col(pe.loc,t)-1) + '^')\r
+                 else:\r
+-                    print ' '*pe.loc + '^'\r
+-                print pe\r
+-            print\r
++                    print(' '*pe.loc + '^')\r
++                print(pe)\r
++            print()\r
++\r
\r
+-        \r
+ class Token(ParserElement):\r
+     """Abstract C{ParserElement} subclass, for defining atomic matching patterns."""\r
+     def __init__( self ):\r
+@@ -3803,4 +3805,4 @@ if __name__ == "__main__":
+ """\r
+ CHANGES\r
+ UnitTests.py\r
+-"""
+\ No newline at end of file
++"""\r
index e10ba4907e0234344220e85a4d7538e43ea1355a..be56c49bbb11f4dc224ed7e31f286e5dad2e37f0 100644 (file)
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python{2_7,3_3} )
 
 inherit distutils-r1
 
-DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+DESCRIPTION="Easy-to-use Python module for text parsing"
 HOMEPAGE="http://pyparsing.wikispaces.com/ https://pypi.python.org/pypi/pyparsing"
 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 
index a2390d4a50b7a53e03e632f243a1f0b3e9d6f35d..9603007e280df5818cb5b6e51810ed4b6791d0fe 100644 (file)
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
 
 inherit distutils-r1
 
-DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+DESCRIPTION="Easy-to-use Python module for text parsing"
 HOMEPAGE="http://pyparsing.wikispaces.com/ https://pypi.python.org/pypi/pyparsing"
 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
 
diff --git a/dev-python/pyparsing/pyparsing-2.0.4.ebuild b/dev-python/pyparsing/pyparsing-2.0.4.ebuild
new file mode 100644 (file)
index 0000000..c2a2abb
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ https://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND="!dev-python/pyparsing:py2 !dev-python/pyparsing:py3"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# no contained in the tarball
+RESTRICT=test
+
+PATCHES=( "${FILESDIR}"/${P}-print.patch )
+
+python_install_all() {
+       local HTML_DOCS=( HowToUsePyparsing.html )
+       if use doc; then
+               HTML_DOCS+=( htmldoc/. )
+               dodoc docs/*.pdf
+       fi
+       use examples && local EXAMPLES=( examples/. )
+       distutils-r1_python_install_all
+}
+
+python_test() {
+       ${PYTHON} unitTests.py || die
+}