dev-dotnet/xsp version bump
authorHeather Cynede <cynede@gentoo.org>
Fri, 14 Aug 2015 07:46:46 +0000 (11:46 +0400)
committerHeather Cynede <cynede@gentoo.org>
Fri, 14 Aug 2015 07:46:46 +0000 (11:46 +0400)
Package-Manager: portage-2.2.20.1

dev-dotnet/xsp/Manifest
dev-dotnet/xsp/files/2.2/mod-mono-server-r1.initd
dev-dotnet/xsp/files/2.2/mod-mono-server.confd
dev-dotnet/xsp/files/2.2/mod-mono-server.initd [new file with mode: 0644]
dev-dotnet/xsp/files/2.2/xsp.confd
dev-dotnet/xsp/files/2.2/xsp.initd
dev-dotnet/xsp/files/aclocal-fix.patch [new file with mode: 0644]
dev-dotnet/xsp/xsp-2014.11.ebuild [new file with mode: 0644]

index 01017d5b3e17b4a51e5bc189d49936e5bf38b1a2..fdfa0372f10e9aecbaf65981418aa0061b1d75fc 100644 (file)
@@ -1 +1,2 @@
+DIST 2014.11.tar.gz 308009 SHA256 6378f0167dc09aaf8f48874b4f9ece3d41d375b168f0cb86a1b2cf52ee937376 SHA512 68e127e1d33da6f7fdcbf2586a48b2da32b1931558e637f10ba6b86cd7e6bf4ad67fc47cfa68703eb65964c270616a04da3eb9f2df14974ecdaa7b979f7fc9b6 WHIRLPOOL 143540614e0c7e509257d3391b06af231acd8732c5528134e4cc6c76a7812531e8f8c6b6059993e1dcd5fcc7516ed44accf44e8e1e4e8917f77ee65dde459815
 DIST xsp-2.10.2.tar.bz2 284801 SHA256 f4657f724167244d9baedf94e1d5747b8f1f53c339c7a11897154c1eb1289d4e SHA512 9b49e3a712e062b9a272e72609eda3cb8139127bc9780d6374a3567f51f15f38233f92252c2e4c22778b1841de66855dfe6a8cf81c97c6ebbf84f71dda0d43dd WHIRLPOOL fce613fedf164f7cd4cf0bae622884a4f7b6747e249d965c4ea23997586371b6a588ad96d66bcc5c6e74f98b76de3f374cd676de164ba1f3a889e4b00b8b6dcc
index 6fda67726d8275f53088db892a6d3c5980df49bf..6ce6a60bcec2a3e2ce671f7b8f7c1295cce28e98 100644 (file)
@@ -1,7 +1,7 @@
 #!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
+# $Id: mod-mono-server-r1.initd,v 1.1 2012/01/22 12:54:29 pacho Exp $
 
 depend() {
        use net
@@ -58,7 +58,7 @@ start() {
                return 1
        fi
 
-       MONO_SHARED_DIR=/tmp ; export MONO_SHARED_DIR
+       export MONO_SHARED_DIR=/tmp
 
        ebegin "Starting mod-mono-server"
 
index dbc5c4cf20c2a2ee6b9e28ceb5105ef81fb72420..7cefdbea49b4b07cb2d0672465b04ddfddc7b4ec 100644 (file)
@@ -1,5 +1,5 @@
 # Config file for /etc/init.d/mod-mono-server
-# $Id$
+# $Id: mod-mono-server.confd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
 
 # Configuration directives for mod-mono-server.exe. For more information on
 # these variables, see the man page for xsp(1).
diff --git a/dev-dotnet/xsp/files/2.2/mod-mono-server.initd b/dev-dotnet/xsp/files/2.2/mod-mono-server.initd
new file mode 100644 (file)
index 0000000..49119e5
--- /dev/null
@@ -0,0 +1,81 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: mod-mono-server.initd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
+
+depend() {
+       use net
+       after dotnet
+}
+
+start() {
+       [ -z "$MonoServerRootDir" ] && \
+       MonoServerRootDir="/usr/lib/xsp/test"
+       [ -z "$MonoApplications" ] && \
+       MonoApplications="/mono:/usr/lib/xsp/test,/:."
+       [ -z "$UnixSocketFileName" ] && \
+       UnixSocketFileName="/tmp/mod_mono_server"
+       [ -z "$MonoServerAddress" ] && \
+       MonoServerAddress=127.0.0.1
+       [ -z "$MonoServerPort" ] && \
+       MonoServerPort=8080
+       [ -z "$MonoServerVersion" ] && \
+       MonoServerVersion=1
+
+       MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
+--applications ${MonoApplications} --nonstop"
+
+       [ -n "$MonoApplicationsConfigDir" ] && \
+       MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--appconfigdir ${MonoApplicationsConfigDir}"
+
+       case "$MonoServerChannel" in
+       "tcp" )
+               MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--address ${MonoServerAddress} --port ${MonoServerPort}"
+               ;;
+       
+       "unix" )
+               [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
+               MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--filename ${UnixSocketFileName}"
+               ;;
+
+       * )
+               eerror "Please set a valid value for MonoServerChannel"
+               return 1
+               ;;
+       esac
+
+       if [ ${MonoServerVersion} -eq 1 ]; then
+               modmonoserverpath=1.0/mod-mono-server.exe
+       elif [ ${MonoServerVersion} -eq 2 ]; then
+               modmonoserverpath=2.0/mod-mono-server2.exe
+       else
+               eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/xsp"
+               return 1
+       fi
+
+       export MONO_SHARED_DIR=/tmp
+
+       ebegin "Starting mod-mono-server"
+
+       start-stop-daemon --quiet --start \
+               --background \
+               --make-pidfile \
+               --pidfile /var/run/aspnet/mod-mono-server.pid \
+               --chuid aspnet \
+               --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
+               -- $MONO_SERVER_OPTS
+
+       eend $?
+}
+
+stop() {
+       ebegin "Stopping mod-mono-server"
+
+       start-stop-daemon -o --quiet --stop \
+               --pidfile /var/run/aspnet/mod-mono-server.pid
+
+       eend $?
+}
index 1004e7428fa8b0620e4cca6f8feafea9c025aa2e..45a79a52bb63b1e819cb67874b0e7dc43b87c2e9 100644 (file)
@@ -1,5 +1,5 @@
 # Config file for /etc/init.d/xsp
-# $Id$
+# $Id: xsp.confd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
 
 # This is the document root; trailing slash is not necessary
 MonoServerRoot=/usr/lib/xsp/test
index 5b609580ebfa0f918f7a8f48c4d431229edba32d..0432bca7d36e2d9df20342a164f10b386832d316 100644 (file)
@@ -1,7 +1,7 @@
 #!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
+# $Id: xsp.initd,v 1.1 2009/01/18 17:44:04 loki_val Exp $
 
 depend() {
        need net
diff --git a/dev-dotnet/xsp/files/aclocal-fix.patch b/dev-dotnet/xsp/files/aclocal-fix.patch
new file mode 100644 (file)
index 0000000..49a0005
--- /dev/null
@@ -0,0 +1,13 @@
+--- Makefile_old.am    2013-07-30 09:11:50.033962122 +0400
++++ Makefile.am        2013-07-30 09:12:20.843574793 +0400
+@@ -1,10 +1,2 @@
+ SUBDIRS=build man src test tools scripts packaging lib
+ ACLOCAL_AMFLAGS += -I build/m4
+-
+-if UNITTESTS
+-SUBDIRS += unittests
+-endif
+-
+-if BUILD_DOCS
+-SUBDIRS += docs
+-endif
diff --git a/dev-dotnet/xsp/xsp-2014.11.ebuild b/dev-dotnet/xsp/xsp-2014.11.ebuild
new file mode 100644 (file)
index 0000000..c1b957b
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PATCHDIR="${FILESDIR}/2.2/"
+
+inherit base eutils dotnet user autotools autotools-utils
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.mono-project.com/ASP.NET"
+SRC_URI="https://github.com/Heather/xsp/archive/2014.11.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_prepare() {
+       epatch "${FILESDIR}/aclocal-fix.patch"
+
+       if [ -z "$LIBTOOL" ]; then
+               LIBTOOL=`which glibtool 2>/dev/null`
+               if [ ! -x "$LIBTOOL" ]; then
+                       LIBTOOL=`which libtool`
+               fi
+       fi
+       eaclocal -I build/m4/shamrock -I build/m4/shave $ACLOCAL_FLAGS
+       if test -z "$NO_LIBTOOLIZE"; then
+               ${LIBTOOL}ize --force --copy
+       fi
+       eautoconf
+}
+
+src_configure() {
+       myeconfargs=("--enable-maintainer-mode")
+       use test && myeconfargs+=("--with_unit_tests")
+       use doc || myeconfargs+=("--disable-docs")
+       eautomake --gnu --add-missing --force --copy #nowarn
+       autotools-utils_src_configure
+}
+
+src_compile() {
+       autotools-utils_src_compile
+}
+
+pkg_preinst() {
+       enewgroup aspnet
+       enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_install() {
+       mv_command="cp -ar" autotools-utils_src_install
+       newinitd "${PATCHDIR}"/xsp.initd xsp
+       newinitd "${PATCHDIR}"/mod-mono-server-r1.initd mod-mono-server
+       newconfd "${PATCHDIR}"/xsp.confd xsp
+       newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server
+
+       keepdir /var/run/aspnet
+}