Add patch to fix bug #157752 thanks to Grant McDorman for reporting; correct dependen...
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Fri, 22 Dec 2006 16:06:09 +0000 (16:06 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Fri, 22 Dec 2006 16:06:09 +0000 (16:06 +0000)
Package-Manager: portage-2.1.2_rc3-r9

media-sound/amarok/ChangeLog
media-sound/amarok/amarok-1.4.3-r1.ebuild
media-sound/amarok/amarok-1.4.4-r3.ebuild [new file with mode: 0644]
media-sound/amarok/files/digest-amarok-1.4.4-r3 [new file with mode: 0644]

index 37fe7968da345a756814b98f4fbd89a5948aeb37..b0bfdb1e5b0a2e47a3f51be604395465ee6d5bf3 100644 (file)
@@ -1,6 +1,20 @@
 # ChangeLog for media-sound/amarok
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.185 2006/12/01 20:29:39 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.186 2006/12/22 16:06:09 flameeyes Exp $
+
+*amarok-1.4.4-r3 (22 Dec 2006)
+
+  22 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+  -files/amarok-1.4.4-asneeded.patch,
+  -files/amarok-1.4.4-lastfm+xine-lib-1.1.3.patch,
+  -files/amarok-1.4.4-musicbrainz.patch,
+  -files/amarok-1.4.4-podcast-fix.patch, -files/amarok-1.4.4-sparc.patch,
+  amarok-1.4.3-r1.ebuild, -amarok-1.4.4.ebuild, -amarok-1.4.4-r1.ebuild,
+  -amarok-1.4.4-r2.ebuild, +amarok-1.4.4-r3.ebuild:
+  Add patch to fix bug #157752 thanks to Grant McDorman for reporting; correct
+  dependency for postgresql/libpq, thanks to Julien Allanos in bug #158812;
+  remove old version, move patches on their own tarball to reduce size of
+  filesdir.
 
   01 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org>
   amarok-1.4.4-r2.ebuild:
index 2cd2dae2eb4fea281d189a1d5887b6aca6dfc002..b038cd1fc3f5999e7d1b0b0fbd5417c9b7d432b9 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.3-r1.ebuild,v 1.10 2006/11/23 17:40:51 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.3-r1.ebuild,v 1.11 2006/12/22 16:06:09 flameeyes Exp $
 
 LANGS="az bg br ca cs cy da de el en_GB es et fi fr ga gl he hi hu is it ja ka
 km ko lt ms nb nl nn pa pl pt pt_BR ro ru rw sl sr sr@Latn sv ta tg th tr uk uz
@@ -32,7 +32,7 @@ DEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
        >=media-libs/xine-lib-1.1.2_pre20060328-r8
        >=media-libs/taglib-1.4
        mysql? ( >=virtual/mysql-4.0 )
-       postgres? ( dev-db/postgresql )
+       postgres? ( dev-db/libpq )
        opengl? ( virtual/opengl )
        visualization? ( media-libs/libsdl
                                         =media-plugins/libvisual-plugins-0.4* )
diff --git a/media-sound/amarok/amarok-1.4.4-r3.ebuild b/media-sound/amarok/amarok-1.4.4-r3.ebuild
new file mode 100644 (file)
index 0000000..1953be1
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.4-r3.ebuild,v 1.1 2006/12/22 16:06:09 flameeyes Exp $
+
+LANGS="af ar az bg br ca cs cy da de el en_GB es et fi fr ga gl he hi hu is it
+ja ka km ko lt ms nb nl nn pa pl pt pt_BR ro ru rw sk sl sq sr sr@Latn sv ta tg
+th tr uk uz zh_CN zh_TW"
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde eutils flag-o-matic
+
+PKG_SUFFIX=""
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${P/_/-}"
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+SRC_URI="mirror://kde/stable/amarok/${PV}/src/${MY_P}.tar.bz2
+       mirror://gentoo/${P}-gentoo.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aac kde mysql noamazon opengl postgres
+visualization ipod ifp real njb mtp musicbrainz"
+# kde: enables compilation of the konqueror sidebar plugin
+
+RDEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+       >=media-libs/xine-lib-1.1.2_pre20060328-r8
+       >=media-libs/taglib-1.4
+       mysql? ( >=virtual/mysql-4.0 )
+       postgres? ( dev-db/libpq )
+       opengl? ( virtual/opengl )
+       visualization? ( media-libs/libsdl
+                                        =media-plugins/libvisual-plugins-0.4* )
+       ipod? ( >=media-libs/libgpod-0.3 )
+       aac? ( media-libs/libmp4v2 )
+       ifp? ( media-libs/libifp )
+       real? ( media-video/realplayer )
+       njb? ( >=media-libs/libnjb-2.2.4 )
+       mtp? ( media-libs/libmtp )
+       musicbrainz? ( media-libs/tunepimp )
+       =dev-lang/ruby-1.8*"
+
+DEPEND="${RDEPEND}"
+
+need-kde 3.3
+
+PATCHES="${WORKDIR}/${P}-gentoo/*.patch"
+
+src_compile() {
+       # Extra, unsupported engines are forcefully disabled.
+       local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+                                 $(use_with opengl) --without-xmms
+                                 $(use_with visualization libvisual)
+                                 $(use_enable !noamazon amazon)
+                                 $(use_with ipod libgpod)
+                                 $(use_with aac mp4v2)
+                                 $(use_with ifp)
+                                 $(use_with real helix)
+                                 $(use_with njb libnjb)
+                                 $(use_with mtp libmtp)
+                                 $(use_with musicbrainz)
+                                 --with-xine
+                                 --without-mas
+                                 --without-nmm"
+
+       kde_src_compile
+}
diff --git a/media-sound/amarok/files/digest-amarok-1.4.4-r3 b/media-sound/amarok/files/digest-amarok-1.4.4-r3
new file mode 100644 (file)
index 0000000..262445f
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 1eb17420bc9036303958da5a2567e611 amarok-1.4.4-gentoo.tar.bz2 2830
+RMD160 75c42ba3bab6aa363aa71bfd17d9532555abc040 amarok-1.4.4-gentoo.tar.bz2 2830
+SHA256 d874db4cd1b63084df4c20b26ef461e95c242579c4d6e4ca80ccff046d149b33 amarok-1.4.4-gentoo.tar.bz2 2830
+MD5 56a9aec42088c338b81252f8e0651781 amarok-1.4.4.tar.bz2 17635707
+RMD160 61cd2748ce0111f4ba388a71e9504abb7362b0d7 amarok-1.4.4.tar.bz2 17635707
+SHA256 760d30337cb73c86b9298e5c2c9836b3a753c39805b54f75b1eea82c15e9a0ea amarok-1.4.4.tar.bz2 17635707