projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9efdf83
)
sci-physics/root: use same compiler for C++ and CUDA in live ebuild
author
Guilherme Amadio
<amadio@gentoo.org>
Wed, 1 Apr 2020 11:28:30 +0000
(13:28 +0200)
committer
Guilherme Amadio
<amadio@gentoo.org>
Wed, 1 Apr 2020 11:28:43 +0000
(13:28 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
sci-physics/root/root-9999.ebuild
patch
|
blob
|
history
diff --git
a/sci-physics/root/root-9999.ebuild
b/sci-physics/root/root-9999.ebuild
index 5a0ccb7679d6a7d2884a8362c8cb4cfb3c5da868..60e7f05e2b1614b1ef67e6a8c907d5b7c88b579a 100644
(file)
--- a/
sci-physics/root/root-9999.ebuild
+++ b/
sci-physics/root/root-9999.ebuild
@@
-154,6
+154,9
@@
src_prepare() {
src_configure() {
local mycmakeargs=(
+ -DCMAKE_C_COMPILER=$(tc-getCC)
+ -DCMAKE_CXX_COMPILER=$(tc-getCXX)
+ -DCMAKE_CUDA_HOST_COMPILER=$(tc-getCXX)
-DCMAKE_C_FLAGS="${CFLAGS}"
-DCMAKE_CXX_FLAGS="${CXXFLAGS}"
-DCMAKE_CXX_STANDARD=$((usev c++11 || usev c++14 || usev c++17) | cut -c4-)