dev-python/pyftpdlib: bump to 1.5.4, drop pypy and some arches.
authorLouis Sautier <sautier.louis@gmail.com>
Sat, 12 May 2018 15:03:01 +0000 (17:03 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Wed, 30 May 2018 21:21:51 +0000 (23:21 +0200)
Add missing sphinx dependency for doc build, disable intersphinx.

Package-Manager: Portage-2.3.31, Repoman-2.3.9
RepoMan-Options: --force
Closes: https://github.com/gentoo/gentoo/pull/8363

dev-python/pyftpdlib/Manifest
dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild [new file with mode: 0644]

index 2eaa8bb9570b12ac1c51f46acf81362b5b1792f8..b1ab75204bb58963acb6e957fd1d260ad9270691 100644 (file)
@@ -1,2 +1,3 @@
 DIST pyftpdlib-1.5.1.tar.gz 127582 BLAKE2B 00233ab4acf5aae4902384f514de0d6da9a55b7312b7744ce3f16fd222b5abeae0c65f0f9309ff40d0cbd960baee2c269a1fc6ba72ed8f700c7dbfd47e646a8a SHA512 81bb634aef7190d97b5939b998c8dd8caf1ce77c2ca66d085826880590a03e7fe4aeefb5eb67f30f25b984962eaae740c4c8c1d5900909029702e37c36bb2b9b
 DIST pyftpdlib-1.5.3.tar.gz 183189 BLAKE2B dd563f59ff21b2059e1c6d6ac6015561d5e0de07b52ea212589afea61abe63a2a61deed86bb133969c8dc99b826b7e23ddf071e0b28ac7b84a066f3fa7f31d90 SHA512 f0e56f170fa77e0866cbbead52ad52276ee45b6c3244557bc59cd2bf599934ae4414a684661d4d47f76098b3da19e23c1a037aaa07a6a81f8d1be14b90191517
+DIST pyftpdlib-1.5.4.tar.gz 184986 BLAKE2B 6973b1f7e0fc0c89eb5d79e082690a706b56553ad4b2ece68a8216bb99c185d770475e349402ec71baf1bb06e5ecca5be2a3c52512f0d8283c4cc249bc28a949 SHA512 6eb308021dad28c1c51a88b366947a71b7bc1802571dc14cedf3a264bd0cb8504ef990d7e3110d10709f971d4d5b0001bee859b58fb4d02a1b0d46532acc9295
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
new file mode 100644 (file)
index 0000000..bc5c598
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="https://github.com/giampaolo/pyftpdlib https://pypi.org/project/pyftpdlib/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~m68k ~mips ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples ssl test"
+
+RDEPEND="
+       ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+       )
+       test? (
+               ${RDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/psutil[${PYTHON_USEDEP}]
+               dev-python/pyopenssl[${PYTHON_USEDEP}]
+               dev-python/pysendfile[${PYTHON_USEDEP}]
+       )
+"
+
+python_prepare_all() {
+       sed -i "s/'sphinx.ext.intersphinx'//" docs/conf.py || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       if use doc; then
+               sphinx-build docs docs/_build/html || die
+               HTML_DOCS=( docs/_build/html/. )
+       fi
+}
+
+python_test() {
+       "${EPYTHON}" ${PN}/test/runner.py || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       if use examples; then
+               docinto examples
+               dodoc -r demo/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]] && \
+               [[ ${PYTHON_TARGETS} == *python2_7* ]] && \
+               ! has_version dev-python/pysendfile ; then
+               elog "dev-python/pysendfile is not installed"
+               elog "It can considerably speed up file transfers for Python 2"
+       fi
+}