dev-libs/libgweather: bump to 3.26.2
authorMart Raudsepp <leio@gentoo.org>
Sun, 9 Sep 2018 12:34:40 +0000 (15:34 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 9 Sep 2018 13:34:12 +0000 (16:34 +0300)
Package-Manager: Portage-2.3.49, Repoman-2.3.10

dev-libs/libgweather/Manifest
dev-libs/libgweather/libgweather-3.26.2.ebuild [new file with mode: 0644]

index 2c28b2e3e80aa9ce131ccba859cd68f8110e74df..4165a29d828abda5dcc0e15e73bee7c81e113948 100644 (file)
@@ -1 +1,2 @@
 DIST libgweather-3.24.1.tar.xz 3350680 BLAKE2B 9265cb3c280446d5f380f62b60efb5578a7a401e3291d12e3824d8e7eacc582761226b0aaebb0439318bd48b9ad5429a1b6d89eb0220a82650c43be8aa337e2d SHA512 564464d7a18a8e0320871ea418b1163163941c950c5acea5ee65a087e44c4d81e019e2e3e4cb6751989f823cbb7c5691713d3dcef72aeaf6ff264e61b6f7b4b4
+DIST libgweather-3.26.2.tar.xz 3409528 BLAKE2B 1c5cdc7125aac8df95e97db8fa1d63bcb06865e70691621bc3a1c0ece2e602862cef9a2a5daa2ebbc5fa7eaefa32bf89507f1eef8fa4eeff294d43132e83fab4 SHA512 75b936f93814005b4317dcb51777036f589f343526428d9a74de96aac1badd4fe81c117184e2bff84a7a3078d6f2a2000e7b63f1e1d80f839b3513cc470fb25b
diff --git a/dev-libs/libgweather/libgweather-3.26.2.ebuild b/dev-libs/libgweather/libgweather-3.26.2.ebuild
new file mode 100644 (file)
index 0000000..81bb7f8
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-6" # subslot = 3-(libgweather-3 soname suffix)
+
+IUSE="glade +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+       >=x11-libs/gtk+-3.13.5:3[introspection?]
+       >=dev-libs/glib-2.35.1:2
+       >=net-libs/libsoup-2.44:2.4
+       >=dev-libs/libxml2-2.6.0:2
+       sci-geosciences/geocode-glib
+       >=sys-libs/timezone-data-2010k
+
+       glade? ( >=dev-util/glade-3.16:3.10 )
+       introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+       !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+       >=dev-util/gtk-doc-am-1.11
+       >=dev-util/intltool-0.50
+       >=sys-devel/gettext-0.18
+       virtual/pkgconfig
+       vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+       use vala && vala_src_prepare
+       gnome2_src_prepare
+}
+
+src_configure() {
+       gnome2_src_configure \
+               --disable-static \
+               $(use_enable glade glade-catalog) \
+               $(use_enable introspection) \
+               $(use_enable vala)
+}