dev-python/greenlet: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 20:02:03 +0000 (21:02 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 4 Jan 2018 20:34:51 +0000 (21:34 +0100)
dev-python/greenlet/Manifest
dev-python/greenlet/greenlet-0.4.10.ebuild [deleted file]

index 278b64dd08e4bcaa6d1b3fd5ca2240c910993539..21e2ef46fca24b4da242d1927d4f8169af7a5ae5 100644 (file)
@@ -1,2 +1 @@
-DIST greenlet-0.4.10.zip 82616 BLAKE2B 6e768e94f13db018a11c553288c06d1481eab5f3135ac9c37850bc34800df7fedc9c437a55be7afcd160d13284082b562d1a6d321dd2ee465b5db38f4217083c SHA512 7fc78b14dca079f838647fd99878850cf9e83af781c985362146a11f71c5a700fbac8148273cd1c0ec4ac6ead4cf5bd389e001b8fc1225e87e9b51919d7ecc6c
 DIST greenlet-0.4.12.tar.gz 57319 BLAKE2B 8260e495bb67e1a2b5b593d3513c3e2157a7b68b71fa3cb2a77de3b4ccc21b5d56bab26b6f0caf00cb669f051d22d7d6ad2700059a3d23b9ad7591f3d6608f43 SHA512 f3bf0f82b6e3bc687fc9b89469339cfb05e64518d1e49bc96066e8d47b8559f1c1aa53692cd25d839437a2f1b81df6fd9a4509a1b4063ec4ce1d97b73842e9f6
diff --git a/dev-python/greenlet/greenlet-0.4.10.ebuild b/dev-python/greenlet/greenlet-0.4.10.ebuild
deleted file mode 100644 (file)
index d066407..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Note: greenlet is built-in in pypy
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Lightweight in-process concurrent programming"
-HOMEPAGE="https://pypi.python.org/pypi/greenlet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="-alpha amd64 arm ~arm64 -hppa -ia64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
-
-DEPEND="
-       app-arch/unzip
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile() {
-       if [[ ${EPYTHON} == python2.7 ]]; then
-               local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}
-               append-flags -fno-strict-aliasing
-       fi
-
-       distutils-r1_python_compile
-}
-
-python_compile_all() {
-       use doc && emake -C doc html
-}
-
-python_test() {
-       "${PYTHON}" run-tests.py -n || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/_build/html/. )
-       distutils-r1_python_install_all
-}