dev-python/snakeoil: dropping py2 support in live ebuild
authorTim Harder <radhermit@gentoo.org>
Mon, 4 Jun 2018 22:56:07 +0000 (18:56 -0400)
committerTim Harder <radhermit@gentoo.org>
Mon, 4 Jun 2018 23:33:29 +0000 (19:33 -0400)
And update test deps.

dev-python/snakeoil/snakeoil-9999.ebuild

index 38a023db443b7f2464ca0c8aeb5415eaf2b8e954..431ad815edf4c20ed469c4e6e19ea9c83ac246b6 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
 PYTHON_REQ_USE="threads(+)"
 inherit distutils-r1
 
@@ -22,13 +22,11 @@ SLOT="0"
 IUSE="test"
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/mock[${PYTHON_USEDEP}] )"
-[[ ${PV} == 9999 ]] && DEPEND+=" $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' 'python3*')"
-
-python_configure_all() {
-       # disable snakeoil 2to3 caching
-       unset PY2TO3_CACHEDIR
-}
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-mock[${PYTHON_USEDEP}]
+       )"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
 
 python_test() {
        esetup.py test