media-sound/beets: Drop old
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Sep 2018 20:56:36 +0000 (22:56 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 5 Sep 2018 21:06:42 +0000 (23:06 +0200)
Closes: https://bugs.gentoo.org/625974
Package-Manager: Portage-2.3.49, Repoman-2.3.10

media-sound/beets/Manifest
media-sound/beets/beets-1.4.3-r1.ebuild [deleted file]
media-sound/beets/metadata.xml

index 6f517f7471ead080474e7eeb8c54c65a325812c0..e6047ad865d9e8b01d9158339a3caae9efe04c99 100644 (file)
@@ -1,2 +1 @@
-DIST beets-1.4.3.tar.gz 1428494 BLAKE2B 29adc617c4efbb304b05c6bc027a09fd34c11af70b22a86a329fe9048de31828f729114db929e97b103a6f6d8210c0b74716f327f8b4f853f745433fea5f1e14 SHA512 b95a9056abae5da3db7786342e8969b4f9c86c2c4589dd48bad244d28ef3d3da4900d3d3eaee1e45964960c62ecaa8d754a33829e0d7f497f01ecc763c0f492d
 DIST beets-1.4.7.tar.gz 1458621 BLAKE2B f7dd19a7dd92415c29e9b1a7932ba33cb5d43000d35a58b2f42c1487db68c6374dd159960f67e1ac68722693d91d364b24297fb2c0c86a39b82fe5b40a1e739d SHA512 6663a2ffece208a510fce9f5d3dd9c8e617cab60cdb994f7bdb13fd759cfea8882290c75c3cdf4f6de9c7d9b78845b6ed29f98b41c787c89ff8782e4ac3ec152
diff --git a/media-sound/beets/beets-1.4.3-r1.ebuild b/media-sound/beets/beets-1.4.3-r1.ebuild
deleted file mode 100644 (file)
index 20b305a..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-inherit distutils-r1 eutils
-
-MY_PV=${PV/_beta/-beta.}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="A media library management system for obsessive-compulsive music geeks"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="http://beets.io/ https://pypi.org/project/beets/"
-
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
-LICENSE="MIT"
-IUSE="badfiles bpd chroma convert doc discogs flac gstreamer lastgenre lastimport mpdstats ogg opus replaygain test thumbnails web"
-REQUIRED_USE="replaygain? ( gstreamer )"
-
-RDEPEND=">=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]
-       dev-python/jellyfish[${PYTHON_USEDEP}]
-       dev-python/munkres[${PYTHON_USEDEP}]
-       dev-python/requests[${PYTHON_USEDEP}]
-       dev-python/requests-oauthlib[${PYTHON_USEDEP}]
-       >=dev-python/python-musicbrainz-ngs-0.4[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/unidecode[${PYTHON_USEDEP}]
-       >=dev-python/six-1.9[${PYTHON_USEDEP}]
-       >=media-libs/mutagen-1.33[${PYTHON_USEDEP}]
-       badfiles? ( media-sound/mp3val media-libs/flac )
-       bpd? ( dev-python/bluelet[${PYTHON_USEDEP}] )
-       chroma? ( dev-python/pyacoustid[${PYTHON_USEDEP}] )
-       convert? ( media-video/ffmpeg:0[encode] )
-       discogs? ( dev-python/discogs-client[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       mpdstats? ( dev-python/python-mpd[${PYTHON_USEDEP}] )
-       lastgenre? ( dev-python/pylast[${PYTHON_USEDEP}] )
-       lastimport? ( dev-python/pylast[${PYTHON_USEDEP}] )
-       replaygain? (
-               gstreamer? ( media-libs/gstreamer:1.0[introspection]
-                       media-libs/gst-plugins-good:1.0
-                       dev-python/pygobject:3[${PYTHON_USEDEP}]
-                       ogg? ( media-plugins/gst-plugins-ogg )
-                       flac? ( media-plugins/gst-plugins-flac:1.0 )
-                       opus? ( media-plugins/gst-plugins-opus:1.0 ) )
-               )
-       thumbnails? (
-               dev-python/pyxdg[${PYTHON_USEDEP}]
-               dev-python/pathlib[${PYTHON_USEDEP}]
-               || ( dev-python/pillow[${PYTHON_USEDEP}] media-gfx/imagemagick )
-               )
-       web? ( dev-python/flask[${PYTHON_USEDEP}] dev-python/flask-cors[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
-       # remove plugins that do not have appropriate dependencies installed
-       for flag in bpd chroma convert discogs lastgenre lastimport mpdstats replaygain thumbnails web; do
-               if ! use ${flag}; then
-                       rm -r beetsplug/${flag}.py || \
-                       rm -r beetsplug/${flag}/ ||
-                               die "Unable to remove ${flag} plugin"
-               fi
-       done
-
-       for flag in bpd lastgenre web; do
-               if ! use ${flag}; then
-                       sed -e "s:'beetsplug.${flag}',::" -i setup.py || \
-                               die "Unable to disable ${flag} plugin "
-               fi
-       done
-
-       use bpd || rm -f test/test_player.py
-
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       cd test
-       if ! use web; then
-               rm test_web.py || die "Failed to remove test_web.py"
-       fi
-       "${PYTHON}" testall.py || die "Testsuite failed"
-}
-
-python_install_all() {
-       doman man/beet.1 man/beetsconfig.5
-       use doc && dohtml -r docs/_build/html/
-}
index c57948828caeddf106d76ad5774fbfdceab5e341..a30fde9062e050a594f6dfd65500333573a3a6f0 100644 (file)
        </longdescription>
        <use>
                <flag name="badfiles">Validate MP3 &amp; FLAC files</flag>
-               <flag name="bpd">Enable support for <pkg>media-sound/mpd</pkg> server emulation</flag>
-               <flag name="chroma">Enable support for acoustic fingerprinting plugin using <pkg>media-libs/chromaprint</pkg></flag>
                <flag name="chromaprint">Enable support for acoustic fingerprinting plugin using <pkg>media-libs/chromaprint</pkg></flag>
-               <flag name="convert">Enable support for the convert plugin which makes it possible to transcode files</flag>
                <flag name="ffmpeg">Enable support for the convert plugin to transcode files via <pkg>media-video/ffmpeg</pkg></flag>
                <flag name="discogs">Enable support for the discogs API plugin</flag>
                <flag name="lastfm">Enable support for importing personal last.fm playcounts and music genres from last.fm tags</flag>
-               <flag name="lastgenre">Enable support for importing music genres from last.fm tags</flag>
-               <flag name="lastimport">Enable support for importing your last.fm playcounts</flag>
                <flag name="mpd">Enable support for <pkg>media-sound/mpd</pkg> server emulation and statistic gathered from <pkg>media-sound/mpd</pkg></flag>
-               <flag name="mpdstats">Enable support for collecting statistic about listening habits from <pkg>media-sound/mpd</pkg></flag>
-               <flag name="opus">Enable opus support in gstreamer-based replaygain</flag>
                <flag name="replaygain">Enable support for Replay Gain metadata calculation during import</flag>
                <flag name="thumbnail">Enable album thumbnails generation</flag>
-               <flag name="thumbnails">Generate thumbnails for albums</flag>
-               <flag name="web">Enable embedded webserver support through <pkg>dev-python/flask</pkg></flag>
                <flag name="webserver">Enable embedded webserver support through <pkg>dev-python/flask</pkg></flag>
        </use>
        <upstream>