sys-fs/fatcat: add missing dep & include for musl
authorBen Kohler <bkohler@gentoo.org>
Sun, 5 Apr 2020 16:25:27 +0000 (11:25 -0500)
committerBen Kohler <bkohler@gentoo.org>
Sun, 5 Apr 2020 16:25:52 +0000 (11:25 -0500)
Closes: https://bugs.gentoo.org/716116
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
sys-fs/fatcat/fatcat-1.1.0-r1.ebuild [new file with mode: 0644]
sys-fs/fatcat/files/fatcat-include-getopt.patch [new file with mode: 0644]

diff --git a/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild b/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
new file mode 100644 (file)
index 0000000..3fd6f31
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="FAT filesystems explore, extract, repair, and forensic tool"
+HOMEPAGE="https://github.com/Gregwar/fatcat"
+SRC_URI="https://github.com/Gregwar/fatcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!elibc_glibc? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/fatcat-include-getopt.patch )
+
+src_install() {
+       cmake-utils_src_install
+       doman man/${PN}.1
+       dodoc docs/*.md
+}
diff --git a/sys-fs/fatcat/files/fatcat-include-getopt.patch b/sys-fs/fatcat/files/fatcat-include-getopt.patch
new file mode 100644 (file)
index 0000000..a9c9094
--- /dev/null
@@ -0,0 +1,11 @@
+diff -ur a/src/fatcat.cpp b/src/fatcat.cpp
+--- a/src/fatcat.cpp   2020-04-05 11:12:55.773602065 -0500
++++ b/src/fatcat.cpp   2020-04-05 11:13:14.112132604 -0500
+@@ -8,6 +8,7 @@
+ #include "xgetopt/xgetopt.h"
+ #else
+ #include <argp.h>
++#include <getopt.h>
+ #endif
+ #endif