games-rpg/egoboo: remove deprecated games eclass
authorAustin English <wizardedit@gentoo.org>
Sat, 15 Oct 2016 09:06:16 +0000 (04:06 -0500)
committerAustin English <wizardedit@gentoo.org>
Sat, 15 Oct 2016 10:16:39 +0000 (05:16 -0500)
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0

games-rpg/egoboo/egoboo-2.8.1-r1.ebuild [new file with mode: 0644]
games-rpg/egoboo/files/egoboo-2.8.1-gentoo.patch

diff --git a/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild b/games-rpg/egoboo/egoboo-2.8.1-r1.ebuild
new file mode 100644 (file)
index 0000000..4d36a95
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A 3d dungeon crawling adventure in the spirit of NetHack"
+HOMEPAGE="http://egoboo.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+       dev-games/physfs
+       media-libs/libsdl[joystick,video]
+       media-libs/sdl-image
+       media-libs/sdl-mixer[vorbis]
+       media-libs/sdl-ttf
+       net-libs/enet:0
+       virtual/glu
+       virtual/opengl"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+       "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+       edos2unix src/game/platform/file_linux.c \
+               src/game/network.c \
+               src/game/Makefile
+       default
+       sed -i \
+               -e "s:@GENTOO_CONFDIR@:/etc/${PN}:" \
+               -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+               src/game/platform/file_linux.c || die "sed failed"
+       rm -rf src/enet || die
+}
+
+src_compile() {
+       emake -C src/game PROJ_NAME=egoboo-2.x
+}
+
+src_install() {
+       dodoc BUGS.txt Changelog.txt doc/*.txt doc/*.pdf
+
+       insinto /usr/share/${PN}
+       doins -r basicdat modules
+       insinto /etc/${PN}
+       doins -r controls.txt setup.txt
+
+       newbin src/game/egoboo-2.x ${PN}
+
+       newicon basicdat/icon.bmp ${PN}.bmp
+       make_desktop_entry ${PN} Egoboo /usr/share/pixmaps/${PN}.bmp
+}
index 36cb33b55c541ce81e236cf6c8d0d443a130b359..2f1205a4511884cda19d416999f34824fd236f6e 100644 (file)
@@ -1,5 +1,5 @@
---- src/game/platform/file_linux.c.old 2012-04-29 21:45:29.627419281 +0200
-+++ src/game/platform/file_linux.c     2012-04-29 21:45:29.628419211 +0200
+--- a/src/game/platform/file_linux.c   2012-04-29 21:45:29.627419281 +0200
++++ b/src/game/platform/file_linux.c   2012-04-29 21:45:29.628419211 +0200
 @@ -79,9 +79,9 @@
      strncpy( linux_dataPath,   PREFIX "/share/games/egoboo-2.x", SDL_arraysize( linux_dataPath ) );
  #else
@@ -12,8 +12,8 @@
  #endif
  
      // the log file cannot be started until there is a user data path to dump the file into
---- src/game/network.c.old     2012-04-29 20:14:31.482179973 +0200
-+++ src/game/network.c 2012-04-29 20:14:52.077730184 +0200
+--- a/src/game/network.c       2012-04-29 20:14:31.482179973 +0200
++++ b/src/game/network.c       2012-04-29 20:14:52.077730184 +0200
 @@ -37,7 +37,7 @@
  #include "egoboo_setup.h"
  #include "egoboo.h"
@@ -23,8 +23,8 @@
  #include "file_common.h"
  
  #include <stdarg.h>
---- src/game/Makefile.old      2012-04-29 20:17:09.303070070 +0200
-+++ src/game/Makefile  2012-04-29 20:18:21.047023847 +0200
+--- a/src/game/Makefile        2012-04-29 20:17:09.303070070 +0200
++++ b/src/game/Makefile        2012-04-29 20:18:21.047023847 +0200
 @@ -33,8 +33,7 @@
  # the compiler options