app-admin/syslog-ng: drop unused patches
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 20 Sep 2019 13:11:21 +0000 (13:11 +0000)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 20 Sep 2019 15:42:46 +0000 (18:42 +0300)
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12978
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-admin/syslog-ng/files/patches/syslog-ng-3.12.1-json-c-0.13+.patch [deleted file]
app-admin/syslog-ng/files/patches/syslog-ng-3.14.1-fix-automake-1.16-build.patch [deleted file]
app-admin/syslog-ng/files/patches/syslog-ng-3.14.1-fix-tls-client.patch [deleted file]

diff --git a/app-admin/syslog-ng/files/patches/syslog-ng-3.12.1-json-c-0.13+.patch b/app-admin/syslog-ng/files/patches/syslog-ng-3.12.1-json-c-0.13+.patch
deleted file mode 100644 (file)
index 3703bec..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 1b824dd6389e209eab752d5a698c6093f311e3e3 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Bj=C3=B6rn=20Esser?= <besser82@fedoraproject.org>
-Date: Mon, 11 Dec 2017 15:46:06 +0100
-Subject: [PATCH] modules/json: Adaptions for json-c v0.13
-
----
- modules/json/json-parser.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/modules/json/json-parser.c b/modules/json/json-parser.c
-index 0368ed8f7..356df48b9 100644
---- a/modules/json/json-parser.c
-+++ b/modules/json/json-parser.c
-@@ -20,6 +20,8 @@
-  * COPYING for details.
-  */
-+#define JSON_C_VER_013 (13 << 8)
-+
- #include "json-parser.h"
- #include "dot-notation.h"
- #include "scratch-buffers.h"
-@@ -28,7 +30,10 @@
- #include <ctype.h>
- #include <json.h>
-+
-+#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
- #include <json_object_private.h>
-+#endif
- typedef struct _JSONParser
- {
diff --git a/app-admin/syslog-ng/files/patches/syslog-ng-3.14.1-fix-automake-1.16-build.patch b/app-admin/syslog-ng/files/patches/syslog-ng-3.14.1-fix-automake-1.16-build.patch
deleted file mode 100644 (file)
index 4339612..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-From 41dd64e7b11d527f8f3cc6ae13067d0225191538 Mon Sep 17 00:00:00 2001
-From: kokan <peter.kokai@balabit.com>
-Date: Sat, 31 Mar 2018 15:36:08 +0200
-Subject: [PATCH] libsyslog-ng: missing dependency libsecret-storage
-
-Signed-off-by: kokan <peter.kokai@balabit.com>
----
- lib/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/Makefile.am b/lib/Makefile.am
-index af2f44ece2..4a0b11c92f 100644
---- a/lib/Makefile.am
-+++ b/lib/Makefile.am
-@@ -47,7 +47,7 @@ lib_libsyslog_ng_la_LDFLAGS          = -no-undefined -release ${LSNG_RELEASE} \
- lib_test_subdirs                      = lib_filter lib_logproto lib_parser lib_rewrite lib_template lib_stats lib_control
--lib_libsyslog_ng_la_DEPENDENCIES      = lib/eventlog/src/libevtlog.la
-+lib_libsyslog_ng_la_DEPENDENCIES       = lib/eventlog/src/libevtlog.la lib/secret-storage/libsecret-storage.la
- if IVYKIS_INTERNAL
- lib_libsyslog_ng_la_DEPENDENCIES      += lib/ivykis/src/libivykis.la
diff --git a/app-admin/syslog-ng/files/patches/syslog-ng-3.14.1-fix-tls-client.patch b/app-admin/syslog-ng/files/patches/syslog-ng-3.14.1-fix-tls-client.patch
deleted file mode 100644 (file)
index b4046bd..0000000
+++ /dev/null
@@ -1,173 +0,0 @@
-From a4f7b9dc75c2b678466cc104d8ca111bd90fba11 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?L=C3=A1szl=C3=B3=20V=C3=A1rady?= <laszlo.varady@balabit.com>
-Date: Wed, 7 Mar 2018 18:35:09 +0100
-Subject: [PATCH 1/3] tls: fix tls_context_load_key_and_cert()
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-key_file and cert_file are optional (the client cert is not mandatory).
-
-Signed-off-by: László Várady <laszlo.varady@balabit.com>
----
- lib/tlscontext.c                         | 9 +++++++++
- modules/afsocket/transport-mapper-inet.c | 6 +++---
- 2 files changed, 12 insertions(+), 3 deletions(-)
-
-diff --git a/lib/tlscontext.c b/lib/tlscontext.c
-index 510ac2738d..b202c397f3 100644
---- a/lib/tlscontext.c
-+++ b/lib/tlscontext.c
-@@ -599,9 +599,18 @@ _are_key_and_cert_files_accessible(TLSContext *self)
-          file_exists(self->cert_file);
- }
-+static gboolean
-+_client_key_and_cert_files_are_not_specified(TLSContext *self)
-+{
-+  return self->mode == TM_CLIENT && (!self->key_file && !self->cert_file);
-+}
-+
- static TLSContextLoadResult
- tls_context_load_key_and_cert(TLSContext *self)
- {
-+  if (_client_key_and_cert_files_are_not_specified(self))
-+    return TLS_CONTEXT_OK;
-+
-   if (!_are_key_and_cert_files_accessible(self))
-     return TLS_CONTEXT_FILE_ACCES_ERROR;
-   if (!SSL_CTX_use_PrivateKey_file(self->ssl_ctx, self->key_file, SSL_FILETYPE_PEM))
-diff --git a/modules/afsocket/transport-mapper-inet.c b/modules/afsocket/transport-mapper-inet.c
-index 80c0d21801..1afb34b33f 100644
---- a/modules/afsocket/transport-mapper-inet.c
-+++ b/modules/afsocket/transport-mapper-inet.c
-@@ -176,17 +176,17 @@ transport_mapper_inet_async_init(TransportMapper *s, TransportMapperAsyncInitCB
-   TLSContextSetupResult tls_ctx_setup_res = tls_context_setup_context(self->tls_context);
-+  const gchar *key = tls_context_get_key_file(self->tls_context);
-+
-   if (tls_ctx_setup_res == TLS_CONTEXT_SETUP_OK)
-     {
--      const gchar *key = tls_context_get_key_file(self->tls_context);
--      if (secret_storage_contains_key(key))
-+      if (key && secret_storage_contains_key(key))
-         secret_storage_update_status(key, SECRET_STORAGE_SUCCESS);
-       return func(func_args);
-     }
-   if (tls_ctx_setup_res == TLS_CONTEXT_SETUP_BAD_PASSWORD)
-     {
--      const gchar *key = tls_context_get_key_file(self->tls_context);
-       msg_error("Error setting up TLS context",
-                 evt_tag_str("keyfile", key));
-       call_finalize_init_args *args = g_new0(call_finalize_init_args, 1);
-
-From 9e3eae23330442c9e58ae5ccc732457f2d0e694e Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?L=C3=A1szl=C3=B3=20V=C3=A1rady?= <laszlo.varady@balabit.com>
-Date: Wed, 7 Mar 2018 19:39:24 +0100
-Subject: [PATCH 2/3] tlscontext: fix error logging of cert_file
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-file_exists() has a side effect: it logs when the file can't be opened.
-
-Since the && operator is evaluated lazily, the error messages of cert_file
-were not displayed when the first invocation of file_exists failed
-(on key_file).
-
-Signed-off-by: László Várady <laszlo.varady@balabit.com>
----
- lib/tlscontext.c | 6 ++++--
- 1 file changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/lib/tlscontext.c b/lib/tlscontext.c
-index b202c397f3..5a503387c4 100644
---- a/lib/tlscontext.c
-+++ b/lib/tlscontext.c
-@@ -595,8 +595,10 @@ tls_context_load_pkcs12(TLSContext *self)
- static gboolean
- _are_key_and_cert_files_accessible(TLSContext *self)
- {
--  return file_exists(self->key_file) &&
--         file_exists(self->cert_file);
-+  gboolean key_file_exists = file_exists(self->key_file);
-+  gboolean cert_file_exists = file_exists(self->cert_file);
-+
-+  return key_file_exists && cert_file_exists;
- }
- static gboolean
-
-From 3eef78b6ac8016d3eb33b36bd98419d5b086767f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?L=C3=A1szl=C3=B3=20V=C3=A1rady?= <laszlo.varady@balabit.com>
-Date: Wed, 7 Mar 2018 19:43:41 +0100
-Subject: [PATCH 3/3] tlscontext: rename file_exists() to is_file_accessible()
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: László Várady <laszlo.varady@balabit.com>
----
- lib/tlscontext.c | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/lib/tlscontext.c b/lib/tlscontext.c
-index 5a503387c4..73015d2462 100644
---- a/lib/tlscontext.c
-+++ b/lib/tlscontext.c
-@@ -322,7 +322,7 @@ tls_session_free(TLSSession *self)
- }
- static gboolean
--file_exists(const gchar *fname)
-+_is_file_accessible(const gchar *fname)
- {
-   if (!fname)
-     return FALSE;
-@@ -444,7 +444,7 @@ _is_dh_valid(DH *dh)
- static DH *
- _load_dh_from_file(const gchar *dhparam_file)
- {
--  if (!file_exists(dhparam_file))
-+  if (!_is_file_accessible(dhparam_file))
-     return NULL;
-   BIO *bio = BIO_new_file(dhparam_file, "r");
-@@ -528,7 +528,7 @@ tls_context_setup_dh(TLSContext *self)
- static PKCS12 *
- _load_pkcs12_file(const gchar *pkcs12_file)
- {
--  if (!file_exists(pkcs12_file))
-+  if (!_is_file_accessible(pkcs12_file))
-     return NULL;
-   FILE *p12_file = fopen(pkcs12_file, "rb");
-@@ -595,10 +595,10 @@ tls_context_load_pkcs12(TLSContext *self)
- static gboolean
- _are_key_and_cert_files_accessible(TLSContext *self)
- {
--  gboolean key_file_exists = file_exists(self->key_file);
--  gboolean cert_file_exists = file_exists(self->cert_file);
-+  gboolean key_file_accessible = _is_file_accessible(self->key_file);
-+  gboolean cert_file_accessible = _is_file_accessible(self->cert_file);
--  return key_file_exists && cert_file_exists;
-+  return key_file_accessible && cert_file_accessible;
- }
- static gboolean
-@@ -650,10 +650,10 @@ tls_context_setup_context(TLSContext *self)
-         goto error;
-     }
--  if (file_exists(self->ca_dir) && !SSL_CTX_load_verify_locations(self->ssl_ctx, NULL, self->ca_dir))
-+  if (_is_file_accessible(self->ca_dir) && !SSL_CTX_load_verify_locations(self->ssl_ctx, NULL, self->ca_dir))
-     goto error;
--  if (file_exists(self->crl_dir) && !SSL_CTX_load_verify_locations(self->ssl_ctx, NULL, self->crl_dir))
-+  if (_is_file_accessible(self->crl_dir) && !SSL_CTX_load_verify_locations(self->ssl_ctx, NULL, self->crl_dir))
-     goto error;
-   if (self->crl_dir)