dev-cpp/ms-gsl: Version bump to 2.0.0
authorJan Henke <Jan.Henke@taujhe.de>
Sat, 29 Sep 2018 17:08:58 +0000 (19:08 +0200)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 12 Oct 2018 01:30:33 +0000 (18:30 -0700)
Closes: https://bugs.gentoo.org/666410
Closes: https://github.com/gentoo/gentoo/pull/10013
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Signed-off-by: Jan Henke <Jan.Henke@taujhe.de>
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-cpp/ms-gsl/Manifest
dev-cpp/ms-gsl/ms-gsl-2.0.0.ebuild [new file with mode: 0644]

index 605a6a2172e37326f58bab4e8e8fec4d9c59057d..d1b036879f31393a9d42f558a0709ba377b9ba31 100644 (file)
@@ -1 +1,2 @@
 DIST ms-gsl-1.0.0.tar.gz 58920 BLAKE2B 46b71ec1fe57ec311a53895498c375c2313ed1f2858cd6b67d19d92ef10230707ce14fb757c00c92ea3475d787cda400cc449c34d54a54a3d0123f71b87b11ad SHA512 cde55df9540fd08ca8d29a74b2cff360686aa75b01ee1c48bd9782a2d70d1b6eae712a51eaf9b60453f859e466df00345b0a2893137d16490cea8ee54362f7da
+DIST ms-gsl-2.0.0.tar.gz 64726 BLAKE2B ab40725aa38af7c5651e22ebf32d4bd9c27a10be2e206fd4c3c0173ad21da262beddef022b7b158653b185cfc3269f2b6e80d99fe65f601ffc3e770b143b03f8 SHA512 7339527222c8a97a94c0bb4038b3d142045ec5d80995e628574ac96f4d9d13c41ad70fbe0d8390586dc0db8d9ea55107dbc95de80f7335eb78ef9d2e7047d726
diff --git a/dev-cpp/ms-gsl/ms-gsl-2.0.0.ebuild b/dev-cpp/ms-gsl/ms-gsl-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..c3af234
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Guideline Support Library implementation by Microsoft"
+HOMEPAGE="https://github.com/Microsoft/GSL"
+SRC_URI="https://github.com/Microsoft/GSL/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/GSL-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# header only library
+RDEPEND=""
+DEPEND="test? ( ~dev-cpp/catch-1.11.0 )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.0.0-use_system_catch-636828.patch"
+       "${FILESDIR}/${PN}-1.0.0-disable_Werror-644042.patch"
+)
+
+src_configure() {
+       local mycmakeargs=(
+               -DGSL_TEST=$(usex test)
+       )
+       use test && mycmakeargs+=( -DFORCE_SYSTEM_CATCH=ON )
+       cmake-utils_src_configure
+}