projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a7e6cd2
)
dev-python/pytest-xdist: Add missing deps and test
author
Justin Lecher
<jlec@gentoo.org>
Wed, 9 Sep 2015 09:47:15 +0000
(11:47 +0200)
committer
Justin Lecher
<jlec@gentoo.org>
Wed, 9 Sep 2015 09:49:37 +0000
(11:49 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
b/dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
index 57ee098db7cca3870eef0c7beb0fa8e4f63c305e..d6fc2826fc9e60f42ad488864c48275fef0f8678 100644
(file)
--- a/
dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
+++ b/
dev-python/pytest-xdist/pytest-xdist-1.13.1.ebuild
@@
-17,7
+17,16
@@
LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-RDEPEND=""
+RDEPEND="
+ >=dev-python/execnet-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
"
+
+python_test() {
+ find -name __pycache__ -exec rm -r '{}' + || die
+ py.test -vv || die
+}