Fix bad version name
authorDoug Goldstein <cardoe@gentoo.org>
Mon, 24 Oct 2011 21:13:30 +0000 (21:13 +0000)
committerDoug Goldstein <cardoe@gentoo.org>
Mon, 24 Oct 2011 21:13:30 +0000 (21:13 +0000)
Package-Manager: portage-2.1.10.31/cvs/Linux x86_64

sys-apps/seabios/ChangeLog
sys-apps/seabios/Manifest
sys-apps/seabios/seabios-0.6.3_pre20110817.ebuild [new file with mode: 0644]

index 202576ef728ae0335b342714f5dcbc4645388002..d230cb13e3aabd1fe6fbcca80d6cdd79f453f192 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-apps/seabios
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/ChangeLog,v 1.4 2011/10/24 18:32:35 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/ChangeLog,v 1.5 2011/10/24 21:13:30 cardoe Exp $
+
+*seabios-0.6.3_pre20110817 (24 Oct 2011)
+
+  24 Oct 2011; Doug Goldstein <cardoe@gentoo.org>
+  +seabios-0.6.3_pre20110817.ebuild:
+  Fix bad version name
 
   24 Oct 2011; Doug Goldstein <cardoe@gentoo.org>
   seabios-0.6.3_pre20010817.ebuild:
index d920715ef36c41dc0911e31e11dc091e1c48e297..135829116289630c54b374496466372837f84b8e 100644 (file)
@@ -1,3 +1,4 @@
 EBUILD seabios-0.6.3_pre20010817.ebuild 1365 RMD160 b813871bd6a40336d4b9543d1843e0c0e10f8457 SHA1 ec70e44a86c9d97a160cd64c865a48e316c30468 SHA256 8e155db378ea6bf37b4972e4c2e0980f59868caf1a89291afd978c091f15adb5
-MISC ChangeLog 825 RMD160 1badc2b8c75f608f70dbf121b4a6652437ad3507 SHA1 06e94a8cf05655a446bd4941565edf53242473bd SHA256 87269f1e9249428d217f8f56942f5b6b0388d12221bae3e91b128e90934c11c8
+EBUILD seabios-0.6.3_pre20110817.ebuild 1365 RMD160 35a7239dbfb4426f42cf28021ea736e03252d591 SHA1 a1840513c07849d31d03dd8717c6980e4fe08d01 SHA256 4f71e478398684a74ce4e8ed13464d1e2481ba98600d9f4d8024a2992d891b14
+MISC ChangeLog 978 RMD160 144f964f218fdbfa6f94487a10c04789de862dfc SHA1 8ac397ace1930f58015e5f4a944d7be9c3e6fbc5 SHA256 cbd508d340a5c0405dc703f24a9cb07ab57dba7620762f897257564e2ff5bd1e
 MISC metadata.xml 263 RMD160 dfb6b4419fbd63abc11c8a94537cfc2ec9f2b443 SHA1 a14bd41b62c7b296d63ff53cb3f31b395ea56975 SHA256 15b7a062b1daa951b969cfac555896a705973335aeab1b9567c0a413501024d6
diff --git a/sys-apps/seabios/seabios-0.6.3_pre20110817.ebuild b/sys-apps/seabios/seabios-0.6.3_pre20110817.ebuild
new file mode 100644 (file)
index 0000000..3f6244f
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/seabios-0.6.3_pre20110817.ebuild,v 1.1 2011/10/24 21:13:30 cardoe Exp $
+
+EAPI=4
+
+#BACKPORTS=1
+EGIT_COMMIT="8e301472e324b6d6496d8b4ffc66863e99d7a505"
+
+if [[ ${PV} = *9999* || ! -z "${EGIT_COMMIT}" ]]; then
+       EGIT_REPO_URI="git://git.seabios.org/seabios.git"
+       GIT_ECLASS="git-2"
+       SRC_URI=""
+else
+       SRC_URI="http://www.linuxtogo.org/~kevin/SeaBIOS/${P}.tar.gz
+       ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-bp-${BACKPORTS}.tar.bz2}"
+fi
+
+inherit ${GIT_ECLASS} python
+
+if [[ ${PV} = *9999* ]]; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Open Source implementation of a 16-bit x86 BIOS"
+HOMEPAGE="http://www.seabios.org"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+       !app-emulation/qemu
+       !<=app-emulation/qemu-kvm-0.15.0"
+
+pkg_setup() {
+       python_set_active_version 2
+}
+
+src_prepare() {
+       if [[ -z "${EGIT_COMMIT}" ]]; then
+               sed -e "s/VERSION=.*/VERSION=${PV}/" \
+                       -i "${S}/Makefile"
+       else
+               sed -e "s/VERSION=.*/VERSION=${PV}_pre${EGIT_COMMIT}/" \
+                       -i "${S}/Makefile"
+       fi
+}
+
+src_configure() {
+       :
+}
+
+src_compile() {
+       emake out/bios.bin
+#      emake out/vgabios.bin
+}
+
+src_install() {
+       insinto /usr/share/seabios
+       doins out/bios.bin
+#      doins out/vgabios.bin
+}