media-libs/libexif-gtk: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 00:42:55 +0000 (01:42 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 00:42:55 +0000 (01:42 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-libs/libexif-gtk/files/libexif-gtk-0.3.5-confcheck.patch
media-libs/libexif-gtk/libexif-gtk-0.3.5-r2.ebuild

index ed22ca64115f21026aba11347ddaae9c22e9cada..33d130884a4a4f235994dc001c024e90a14fd09a 100644 (file)
@@ -1,5 +1,5 @@
---- configure.in.orig  2004-10-18 15:12:58.000000000 -0400
-+++ configure.in       2006-01-05 19:06:05.000000000 -0500
+--- a/configure.in
++++ b/configure.in
 @@ -52,7 +52,7 @@
  dnl ---------------------------------------------------------------------------
  CPPFLAGS_save="$CPPFLAGS"
index 8afe1081343747d1bbc26647ce48d70c25aea3b5..8cf633a8fe0b0fe9785285c28c7a3868fff01cb2 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
 
 DESCRIPTION="GTK+ frontend to the libexif library (parsing, editing, and saving EXIF data)"
 HOMEPAGE="http://libexif.sf.net"
@@ -11,30 +12,35 @@ SRC_URI="mirror://sourceforge/libexif/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="nls static-libs"
+IUSE="nls"
 
-RDEPEND="x11-libs/gtk+:2
-       >=media-libs/libexif-0.6.12"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
+RDEPEND="
+       dev-libs/glib:2
+       x11-libs/gtk+:2
+       media-libs/libexif:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
 
-DOCS=( ChangeLog )
+PATCHES=(
+       "${FILESDIR}"/${P}-confcheck.patch
+       "${FILESDIR}"/${P}-gtk212.patch
+)
 
 src_prepare() {
-       epatch \
-               "${FILESDIR}"/${P}-confcheck.patch \
-               "${FILESDIR}"/${P}-gtk212.patch
-
+       default
+       mv configure.{in,ac} || die
        AT_M4DIR="m4" eautoreconf
 }
 
 src_configure() {
        econf \
-               $(use_enable static-libs static) \
+               --disable-static \
                $(use_enable nls)
 }
 
 src_install() {
        default
-       rm -f "${ED}"usr/lib*/${PN}.la
+
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }