net-libs/libssh2: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 14:51:22 +0000 (16:51 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 16:38:01 +0000 (18:38 +0200)
net-libs/libssh2/libssh2-1.6.0-r1.ebuild [new file with mode: 0644]
net-libs/libssh2/libssh2-9999.ebuild

diff --git a/net-libs/libssh2/libssh2-1.6.0-r1.ebuild b/net-libs/libssh2/libssh2-1.6.0-r1.ebuild
new file mode 100644 (file)
index 0000000..631d0ba
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+inherit autotools-multilib
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="gcrypt libressl static-libs test zlib"
+
+DEPEND="
+       !gcrypt? (
+               !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+               libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+       )
+       gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+       zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.2-pkgconfig.patch )
+
+src_prepare() {
+       sed -i -e 's|mansyntax.sh||g' tests/Makefile.am || die
+       autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+       # Disable tests that require extra permissions (bug #333319)
+       use test && local -x ac_cv_path_SSHD=
+
+       local myeconfargs=(
+               $(use_with zlib libz)
+               $(usex gcrypt --with-libgcrypt --with-openssl)
+       )
+       autotools-utils_src_configure
+}
index a41ca40951fa3c2c59ad9cca80c9b0ef5f4b3986..8d3718bc08330f4185553e7568a252f2da7087f2 100644 (file)
@@ -15,9 +15,13 @@ SRC_URI=""
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS=""
-IUSE="gcrypt static-libs test zlib"
+IUSE="gcrypt libressl static-libs test zlib"
 
-DEPEND="!gcrypt? ( >=dev-libs/openssl-1.0.1h-r2[${MULTILIB_USEDEP}] )
+DEPEND="
+       !gcrypt? (
+               !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )
+               libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+       )
        gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
        zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
 RDEPEND="${DEPEND}"