dev-ruby/hoe: also adjust gemspec for newer rake
authorHans de Graaff <graaff@gentoo.org>
Tue, 3 Jan 2017 06:50:12 +0000 (07:50 +0100)
committerHans de Graaff <graaff@gentoo.org>
Tue, 3 Jan 2017 06:50:12 +0000 (07:50 +0100)
Package-Manager: portage-2.3.0

dev-ruby/hoe/hoe-3.15.3-r2.ebuild [new file with mode: 0644]

diff --git a/dev-ruby/hoe/hoe-3.15.3-r2.ebuild b/dev-ruby/hoe/hoe-3.15.3-r2.ebuild
new file mode 100644 (file)
index 0000000..3c68ae2
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation"
+HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-13.0"
+
+all_ruby_prepare() {
+       # Skip isolation
+       sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+       # Skip test depending on specifics of gem command name
+       sed -i -e '/test_nosudo/,/^  end/ s:^:#:' test/test_hoe.rb || die
+
+       # Gem.bin_wrapper does not work as expected on Gentoo.
+       sed -i -e 's/Gem.bin_wrapper//' lib/hoe/rcov.rb lib/hoe/publish.rb test/test_hoe_publish.rb || die
+
+       # Fix broken test by including the right plugin first
+       sed -i -e '/test_extensions/a Hoe.plugin :clean' test/test_hoe.rb || die
+
+       # Allow newer rake for compatibility with ruby24, bug 603840
+       sed -i -e 's/12.0/13.0/' Rakefile ../metadata || die
+}
+
+all_ruby_compile() {
+       all_fakegem_compile
+
+       rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+}