dev-python/pillow: fix test dependencies
authorVirgil Dupras <vdupras@gentoo.org>
Wed, 11 Jul 2018 14:38:41 +0000 (10:38 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Wed, 11 Jul 2018 14:38:41 +0000 (10:38 -0400)
Some tests require imagemagick to be installed but, more importantly,
installed with the png USE flag. When imagemagick was installed without
the png use flag, those tests would run and fail.

Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/pillow/pillow-4.3.0-r2.ebuild
dev-python/pillow/pillow-5.2.0.ebuild

index 77e205fdfb54411d8fa757bbb61aef572700f1b3..803aa344a8078d485f401fc0b3990238da9d6aca 100644 (file)
@@ -38,7 +38,10 @@ DEPEND="${RDEPEND}
                dev-python/sphinx[${PYTHON_USEDEP}]
                dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        )
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               media-gfx/imagemagick[png]
+       )
 "
 
 S="${WORKDIR}/${MY_P}"
index 50913f7c98a34a90541c8e329604e52579055f32..ad0c8bde22b625fe377338c8112d7502eb9f4ca5 100644 (file)
@@ -38,7 +38,10 @@ DEPEND="${RDEPEND}
                dev-python/sphinx[${PYTHON_USEDEP}]
                dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
        )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               media-gfx/imagemagick[png]
+       )
 "
 
 S="${WORKDIR}/${MY_P}"