dev-python/ipaddress: Version bump to 1.0.23, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 22 Nov 2019 01:49:53 +0000 (17:49 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 22 Nov 2019 03:15:14 +0000 (19:15 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/ipaddress/Manifest
dev-python/ipaddress/ipaddress-1.0.23.ebuild [new file with mode: 0644]

index a8520965342a91b9836f1e81047d2634d83af581..3e82a884a116dc964c6bb0449a138a7fa3aa448b 100644 (file)
@@ -2,3 +2,4 @@ DIST ipaddress-1.0.14.tar.gz 30429 BLAKE2B cbd9db35c965adca5162db0d263920f537377
 DIST ipaddress-1.0.18.tar.gz 32475 BLAKE2B 7d116b1aad36bc58f9a6769b562e0b6dd260fc497a4fd697cf13d506c8828ba7e63f86f1908ec9cff1f1bb15aa76a0e850c628c30e22d5440df320b3c8ad0328 SHA512 7d1c8cf67db5b55a872783390ca214bb39e243d313311674afe10008e86638838bef5f9e6d703803bdcfde6d27520b1fc19d0adb19d482e27a327fb735aa0312
 DIST ipaddress-1.0.19.tar.gz 32854 BLAKE2B ea6bd0ac5418dca343e39c12e31a96aa6b13b091da05b7afcb3051251d3c8b8ce76a19f1d6b7ad2caf3f0077f6b522c4e0915a7a8eae28a72700732278ae4c6b SHA512 e49d0d0b76c108f985a5d209092495b5839195d9c4d5c975cc17c89e98d9b6bf0983f71f3b183c3974eccf0529cfb22aa8fbe384485be019da3fb74d50f1f4f1
 DIST ipaddress-1.0.22.tar.gz 33051 BLAKE2B ae9145a275d373f07ad3996b9c06007259cde7a03f6389fed2a83d9210dc8f135026d931b2ddf408f5f465b37861c9e998ae2eaac782741a0fa6ae07dd4259c7 SHA512 b0b0bae50c0819c46554f4ca2d14403a054d73cb9df7efd8bde03bd32b7599510a0e8eb7a63bd7cc6af45a035a0fcce38058b0625732472c7f252f72b88a6084
+DIST ipaddress-1.0.23.tar.gz 32958 BLAKE2B 96f8f3065aaa082c67c5468598e78bf928653588333f8f96c47aafea30c6aa5e3abf419f98e6388b9791a8f7e679f7fb31f36bb1d6a274a19b0e8ea434a8cbc1 SHA512 340e2a8698df1868038f55889671442eba17f06ec3f493759d8d0a9bf406eefbe1f67c14ca616f52e5bf2280942dcece7e89fb19de0923bee1ee20e60f48896e
diff --git a/dev-python/ipaddress/ipaddress-1.0.23.ebuild b/dev-python/ipaddress/ipaddress-1.0.23.ebuild
new file mode 100644 (file)
index 0000000..1a0f10b
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="IPv4/IPv6 manipulation library, backport of the ipaddress module"
+HOMEPAGE="https://github.com/phihag/ipaddress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i 's:unittest.main():unittest.main(verbosity=2):' \
+               test_ipaddress.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       "${PYTHON}" test_ipaddress.py || die
+}