app-crypt/libmd: Add live ebuild
authorJeroen Roovers <jer@gentoo.org>
Wed, 23 Oct 2019 12:19:56 +0000 (14:19 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 23 Oct 2019 12:21:18 +0000 (14:21 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
app-crypt/libmd/libmd-99999.ebuild [new file with mode: 0644]

diff --git a/app-crypt/libmd/libmd-99999.ebuild b/app-crypt/libmd/libmd-99999.ebuild
new file mode 100644 (file)
index 0000000..c0ad8d6
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="Message Digest functions from BSD systems"
+HOMEPAGE="https://www.hadrons.org/software/libmd/"
+EGIT_REPO_URI="https://git.hadrons.org/git/libmd.git"
+
+LICENSE="|| ( BSD BSD-2 ISC BEER-WARE public-domain )"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+
+       find "${ED}" -name '*.la' -delete || die
+}