x11-misc/qps: EAPI bump 4 -> 6
authorHarri Nieminen <moikkis@gmail.com>
Wed, 1 Mar 2017 16:47:58 +0000 (18:47 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 1 Mar 2017 20:44:58 +0000 (21:44 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/4091

x11-misc/qps/qps-1.10.16-r1.ebuild [moved from x11-misc/qps/qps-1.10.16.ebuild with 80% similarity]

similarity index 80%
rename from x11-misc/qps/qps-1.10.16.ebuild
rename to x11-misc/qps/qps-1.10.16-r1.ebuild
index 5f69992d97da59f5fe56a53dfe090a18018187f7..f556cf7c1c034227fb545805c038584e8f313434 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=6
 
-inherit eutils qt4-r2
+inherit eutils qmake-utils
 
 DESCRIPTION="Visual process manager - Qt version of ps/top"
 HOMEPAGE="http://qps.kldp.net/projects/qps/"
@@ -20,13 +20,18 @@ DEPEND="dev-qt/qtcore:4
 RDEPEND="${DEPEND}"
 
 src_prepare() {
+       default
        sed -i -e '/strip/d' ${PN}.pro || die "sed failed"
 }
 
+src_configure() {
+       eqmake4 ${PN}.pro
+}
+
 src_install() {
        dobin ${PN}
        doman ${PN}.1
-       dodoc CHANGES
+       einstalldocs
 
        newicon icon/icon.xpm ${PN}.xpm
        make_desktop_entry ${PN} ${PN} ${PN} "System;"